Skip to Content
author's profile photo
Former Member

Form <Program Name> language EN is not active and has no errors

Dear all,

I'm new to SAP development. I have copied the standard RLVSDR40 and made some modification on it. When i tried to print in lt31. I encounter the following error:

"Form <program name> language EN is not active and has no errors".

Any idea about this?? What is the standard procedure of this kind development??

Regards,

Kit

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • author's profile photo
    Former Member
    Posted on Sep 28, 2007 at 07:41 AM

    log on in to the original language an make u r zrlvsdr40 active...............

    reward points if helpful..........

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Ramyav,

      Could you give me more detailed step?? Go to the original language, I'm using english. I have already activated the program.

      Regards,

      Kit

  • author's profile photo
    Former Member
    Posted on Sep 28, 2007 at 08:09 AM

    after doing client copy u need to change the original language of the script also so after doing client copy make a note of zscript name log on to the original language of the script make a change over there !!

    to do that in se71 ...utilities tab convert original language option is there....

    and one more thing

    when doing the copy try copy all the includes ...screens...everything in to that z object......after doing copying assign u r progname form name nace transaction..........................

    reward points if helpful

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Sep 28, 2007 at 08:13 AM

    hi

    first go to SE71 and give Form Name and Original Language of the form and copy it to zform.

    Now open this Zform in change mode and go to Utilities-> change original language to log on language here EN in your case-> and save it.

    Now your Zform is in language EN note tat now when you are opening your zform to modufy you might be trying to change it in DE so change language to EN and then modify it.

    After making changes go to NACE transaction to assign this zform to transaction you are using.

    Nace->choose application->output type->choose your output type->Double click processing routines->you will find one column pdf smartform/scriptname-> here give your zform name

    It will surely work if not get back to me

    Add comment
    10|10000 characters needed characters exceeded