Skip to Content
0

Crystal Reports TLS 1.2 Support Help needed

Sep 07, 2017 at 02:39 PM

816

avatar image
Former Member

We have a website that needs to allow TLS 1.2 connection from Crystal Reports on a web server to our SQL Server (version 2008 R2). The rest of the site works fine -- its just the Crystal Reports that are failing with a "Database Login failed" error message.

We have already tried:

1) Upgrading from Crystal Reports version from XI R2 to 2016 – no change

2) Changing to use Native 11 -- no change

3) Gone to the SAP Crystal Reports website to make sure we had the most recent version of both the 32-bit and 64-bit runtimes – no change

4) Downloaded and updated the Crystal Reports for Visual Studio 2010 – no change

It’s almost like there is a version mismatch somewhere because Crystal Reports 2016 notes the version as 14.2.4.2410 but all the controls in Visual Studio 2010 reference 13.0.2000.0

What are we missing????

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Don Williams
Sep 08, 2017 at 07:37 PM
0

Microsoft released a patch for TLS 1.2 support, search there for a fix.

CR supports whatever the OS supports.

Oh and 13.0.2000.0 is the assembly version, never changes unless using SP 21, now most are 13.0.3500.0

Go here for the latest:

https://wiki.scn.sap.com/wiki/display/BOBJ/Crystal+Reports%2C+Developer+for+Visual+Studio+Downloads

Share
10 |10000 characters needed characters left characters exceeded