Skip to Content
author's profile photo
Former Member

XLR with Office 2007

I have just upgraded my client to patch 29 of SAP B1 2005A SP01. They have MS Office 2007 on some of their client machines. I also upgraded XL Reporter to the latest patch on the portal (29). At the XL Reporter upgrade step the users with Office 2007 got error messages about Excel not being installed (it is - Office 2007 Excel) and then when they tried to start the addon they get the error message " Runtime error 430 - Class does not support automation or does not support expected interface". This does not occur with the users who do not have office 2007. Is there some setting in Excel 2007 that is required for XLR to work?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    author's profile photo
    Former Member
    Posted on Sep 27, 2007 at 06:23 AM

    Hi Tracey,

    XL Reporter is not compatible with Office 2007. On the SAP Portal the information is :

    XL Reporter 2005 does support Microsoft® Office 2007 as of XL Reporter 2005 SP01 PL29.

    I think you will have to ask your customer to switch to Office 2003 for XL Reporter 2005 to work.

    For more information on compatibility of SBO, check the link:

    https://websmp103.sap-ag.de/smb/sbo/platforms

    Hope this helps!

    Regards,

    Gyanesh Rupani

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Gyanesh, yes it appears that SAP are confused too. I got conflicting answers on this but the upshot is that even the latest patch of XLR (29) for 2005A SP01 is NOT compatible with Excel 2007. Oh well, 2 days wasted upgrading 100 users to the latest B1 patch for nothing...sigh...