Skip to Content
0
Former Member
Sep 26, 2007 at 01:16 PM

Problem executing BAPI_ADDRESSEMPUS_CHANGE with SAP JCO

21 Views

Hi All,

i am trying to change IT0006 FOR A US employee, using BAPI_ADDRESSEMPUS_CHANGE. Its working fine when i directly execute in SAP, but it is throwing an error when conneected thru SAP Jco.

I tried using BAPI_ADDRESSEMP_CHANGE still no luck.

but both these BAPIS work fine for any other country's employees except US.

so this confirms that its not the problem with bapi.

Little background:

The error says "SAP ERROR:make an entry in all required fields".I was getting this error while executing the bapi directly in SAP so on further investigation learned that there was a dynamic action written to update Residential tax infotype IT0207whenever a change is made to IT0006 for US employee, and unlike PA30 where the pop up wld come for IT0207 due to Dynamic actions,it wasnt happeneing in se37 where i was executing the bapi.

Now i removed dyn action for it0006, now error is gone when bapi is executed in SAP but still when i connect thru SAP Jco the error persists. i feel this change of removing dyn action is not recgnised by Jco or not updated.(because in portal too there is no interface for IT207 which it is looking for) does the old data cached in jco? why inspite of removing dyn action i am getting that error?

i am passing in all the mandatory fields,like postal code,add line 1 etc etc. ist not that problem..its still considering filling in IT207 which i disabled.

now coming to most confusing and funny part of it...when connected thru JCO if debugger is ON...the bapi updates IT0006 without any problem...it defies my logic..no error is thrown nor does the transaction stops anywhere. Somehow magically bapi works fine when debugger is on..then the error of filling in mandatory fields disappears.

this issue is for r/3 4.7 connected thru SAP Jco ver.2.1.8

any input are highly appreciated.

thanks in advance