Skip to Content
0

Cloud Platform Web IDE Multi-Cloud HTTP 404 when running app

Sep 05, 2017 at 09:49 AM

62

avatar image

Hi,

I have created a basic UI5 template application in the CP Web IDE Multi-Cloud version. When I click the "Run" button I am getting a HTTP 404 error. The generated URL is:

https://webidetesting5162487- . dispatcher.hanatrial.ondemand.com/webapp/index.html?hc_orionpath=%2FDI_webide_di_workspaceo9wiqftv6sjnuy8n%2FTestUI5part1∨igional-url=index.html&sap-ui-appCacheBuster=..%2F&sap-ui-xx-componentPreload=off

Can anyone help?

I have tried deploying the app to CP and it is working as expected, yet the Web IDE "Run" functionality still does not work. The deployment URL is:

https://testui5part1- . dispatcher.hanatrial.ondemand.com/index.html?hc_reset

My trial account is registered in Europe.

Thanks in advance,
JB

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Michal Keidar
Sep 05, 2017 at 07:32 PM
0

Hi Jonathan, I will forward this to our experts.

Share
10 |10000 characters needed characters left characters exceeded
Gadi Sneh
Sep 06, 2017 at 07:11 AM
0

Hi,

This issue might be related to missing destination in your account.

Can you please try the following?

  1. Open the account cockpit (From web IDE: Tools -> SAP Cloud Platform Cockpit)
  2. On the left menu, go to Connectivity -> Destinations
  3. Check if you have a destination named 'webide_di'

Please let us know if such destination exist or not.

If it does, please export it from the cockpit and attach it so we'll be able to review it.

Regards,

Gadi

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Gadi,

Thanks for your response. The destination 'webide_di' does exist in Connectivity > Destinations. I have attached it below.

webide-di.txt

Regards,

JB

webide-di.txt (287 B)
0

Hi,

The destination had wrong URL in it. It pointed to the html5 app, while it should point to the java app.

Please import the attached fix destination, wait for 10 min and try your scenario (running an app) again.

Regards,

Gadi

webide-di.txt

webide-di.txt (290 B)
webide-di.txt (290 B)
0