Skip to Content
author's profile photo
Former Member

Alert Configuration

Hi guys,

I am trying to configure alerts in XI..

I followed the Blog 2328(Alerts - step by step) and 2327(Alerts - troubleshooting Guide) by Michal...and also SAP Note : 750287.and now when i am trying to click on alert Configuration and Alert Inbox in RWb ...i am getting error message related to BSP Page and FQDN.

Now I want to know

1. What is the possible cause of error...?

2. Where i need to make an entry for hostname_full ? Kindly come up with transactions and menu path also..

As per my knowledge my RWB is not able to connect to BSP in XI because of some domain related issues for this i need to make an entry in XI mentioning fully qualified domain name...now which TA to use and where to make an entry isthe issue..

Let me know if i missed something...and any helpful thread or blog related to this..

Points will be rewarded...:-)

Regards,

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

11 Answers

  • Best Answer
    Posted on Sep 25, 2007 at 05:12 AM

    Option 1:

    Go to exchange profile

    http://<IP>:<Port>/exchangeProfile/index.html

    Then RuntimeWorkbench -> com.sap.aii.rwb.server.centralmonitoring.r3.ashost

    Option 2:

    Go to transaction SMICM --> Go to (menu at the top ) --> parameters --> Display.

    Here scroll across the list of parameters displayed and you will find the Fully Qualified hostname against name , icm/host_name_full

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 25, 2007 at 09:59 AM

    Santosh,

    I had a similar error recently, In our case the system wasnt set up properly and the profile parameter needed to be set (icm/host_name_full). this is why the FQDN (fully qualified domain name) could not be determined when BSP were generated.

    I gave our basis people this link and it helped them solve the problem (sorry I didnt do it myself so I dont know exactly what they did...)

    Business Server Pages- Fully Qualified Domain Name (FQDN) https://www.sdn.sap.com/irj/sdn/wiki?path=/display/bsp/fullyQualifiedDomainName%28FQDN%29&

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Sep 26, 2007 at 09:50 AM

    -->Under Misc you can see the icm/host_name_full parameter which should contain full domain host name.

    Hi Prasanthi , I know that In SMICM i mustbe able to see FQDN but if not...then what to do..?

    My question is where i have to make an entry so that i can see the right values in SMICM..

    Hope you got my point....I have already made an entry RWB..

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Santosh,

      >> <i>I have already made an entry RWB</i>

      Once you make changes in the exchange profile, have you restarted the J2ee server to reflect the changes.

      >> <i>My question is where i have to make an entry so that i can see the right values in SMICM.. </i>

      The parameter SAPLOCALHOSTFULL is set in a profile file, the ICM uses this value. Refer SAP note: 773830 .

      So better contact to ur basis team to get this done.

      Thanks!!

  • author's profile photo
    Former Member
    Posted on Sep 26, 2007 at 11:04 AM

    Prasanthi...

    -->Once you make changes in the exchange profile, have you restarted the J2ee server to reflect the changes.

    No, i didn't...but Definitely i will if needed..But i heard that just by refreshing the RWB ..it should work...by using ...

    <b>http://xiserver:50000/rwb/rtc?op=init</b>

    what you say..?

    >> My question is where i have to make an entry so that i can see the right values in SMICM..The parameter SAPLOCALHOSTFULL is set in a profile file, the ICM uses this value. Refer SAP note: 773830 .

    <b>where can i find this parameter SAPLOCALHOSTFULL ?</b>

    Our Basis team is not that much competent enough in XI...that's why i have to jump in... 😊

    BTW thanx for the quick responses...but keep looking intro the thread.....will ping you back once server will restart....Points rewarded...:-)

    Add comment
    10|10000 characters needed characters exceeded

    • Santhosh,

      The parameter SAPLOCALHOSTFULL is maintained in the RZ10 and once u done with this, you need to activate it. After this we need to restart SMICM to reflect the change. By using tcode RZ11 we can verify whether this parameter is active or not.

      Also check this thread it might be helpfull...

      icm/host_name_full is not effected.

      I got this info from my basis friend 😉 ...and hope it will be helpful for u...to resolve ur problem.

      Thanks,

      Prasanthi.

  • author's profile photo
    Former Member
    Posted on Sep 25, 2007 at 05:08 AM

    hi

    refer the blogs.

    /people/michal.krawczyk2/blog/2005/09/09/xi-alerts--step-by-step - Alert Configuration

    /people/michal.krawczyk2/blog/2005/09/09/xi-alerts--troubleshooting-guide - Trouble shoot alert config

    Thank you

    Indira D

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Sep 25, 2007 at 06:20 AM

    Indira ,

    I have already followed the above blogs by michal and i have mentioned that thing in the beginning of the thread also.

    Shabarish,

    <b>But where i have to make this entry...</b>

    <b>I mean the transactions and what type of entry....As in SMICM i can see my both alertinbox services are running but when i right click on alertinbox and test the alertinbox service i am getting BSP server page error beacuse of not mentioning of FQDN.</b>

    Can anybody explain me the whole flow...means how alerts work..from which place it is picking the entry for FQDN.....

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Sep 25, 2007 at 06:36 AM

    Farooq,

    I am working on PI 7.0...just want to know where the entry for FQDN needs to be maintained .

    Thanks and Regards,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Santosh

      Goto the home page i.e http://<host>:<port>/rep/support/admin/index.html

      Click on Administration --> Exchange Profile ( under Administration of properties )

      RuntimeWorkbench -> com.sap.aii.rwb.server.centralmonitoring.r3.ashost

      - lalit -

  • Posted on Sep 25, 2007 at 07:05 AM

    Hi Santosh,

    The parameter saplocalhostfull and icm/host_name_full should contain the host.fqdn.

    Also refer to SAP note 768456.

    Regards,

    Prasanthi.

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Sep 25, 2007 at 07:10 AM

    hi Prasanthi,

    -->The parameter saplocalhostfull and icm/host_name_full should contain the host.fqdn.

    but where will get these parameters in which screen or Transaction...?

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

    • Go to SMICM --> Goto --> parameters ---> Display

      Under Misc you can see the icm/host_name_full parameter which should contain full domain host name.

      Also check the property "com.sap.aii.rwb.server.centralmonitoring.httpport" under "RuntimeWorkbench" in the ExchangeProfile and it should contain the http port address.

      Thanks!!

  • author's profile photo
    Former Member
    Posted on Sep 26, 2007 at 09:54 AM

    -->Under Misc you can see the icm/host_name_full parameter which should contain full domain host name.

    Hi Prasanthi , I know that In SMICM i mustbe able to see FQDN but if not...then what to do..?

    My question is where i have to make an entry so that i can see the right values in SMICM..

    Hope you got my point....I have already made an entry in RWB..

    Regards,

    Add comment
    10|10000 characters needed characters exceeded