Skip to Content
avatar image
Former Member

Dispatcher stopped

Hi All

We have the SAP R/3 Version 4.7E. About a couple of days back the server was shutdown as part of routine maintenance work. But when it was restarted, the dispatcher stopped running.

The database is running, yet the dispatcher is not. I've copied the dev_w1 trace file here. Kindly let us know your suggestions.

-


trc file: "dev_w1", trc level: 1, release: "620"

-


*

  • ACTIVE TRACE LEVEL 1

  • ACTIVE TRACE COMPONENTS all, M

*

B

B Mon Sep 24 13:44:59 2007

B create_con (con_name=R/3)

B Loading DB library 'E:\usr\sap\V5C\SYS\exe\run\dboraslib.dll' ...

B Library 'E:\usr\sap\V5C\SYS\exe\run\dboraslib.dll' loaded

B Version of 'E:\usr\sap\V5C\SYS\exe\run\dboraslib.dll' is "620.02", patchlevel (0.876)

B New connection 0 created

M systemid 560 (PC with Windows NT)

M relno 6200

M patchlevel 0

M patchno 1101

M intno 20020600

M pid 2424

M

M ***LOG Q0Q=> tskh_init, WPStart (Workproc 1 2424) [dpxxdisp.c 1058]

I MtxInit: -2 0 0

M

M Mon Sep 24 13:45:02 2007

M DpShMCreate: sizeof(wp_adm) 14448 (1204)

M DpShMCreate: sizeof(tm_adm) 1971408 (9808)

M DpShMCreate: sizeof(wp_ca_adm) 24000 (80)

M DpShMCreate: sizeof(appc_ca_adm) 8000 (80)

M DpShMCreate: sizeof(comm_adm) 290000 (580)

M DpShMCreate: sizeof(wall_adm) (38456/34360/64/184)

M DpShMCreate: SHM_DP_ADM_KEY (addr: 06250040, size: 2383128)

M DpShMCreate: allocated sys_adm at 06250040

M DpShMCreate: allocated wp_adm at 06250950

M DpShMCreate: allocated tm_adm_list at 062541C0

M DpShMCreate: allocated tm_adm at 062541E8

M DpShMCreate: allocated wp_ca_adm at 064356B8

M DpShMCreate: allocated appc_ca_adm at 0643B478

M DpShMCreate: allocated comm_adm_list at 0643D3B8

M DpShMCreate: allocated comm_adm at 0643D3D0

M DpShMCreate: allocated ca_info at 064840A0

M DpShMCreate: allocated wall_adm at 064840A8

X

X Mon Sep 24 13:45:07 2007

X EmInit: MmSetImplementation( 2 ).

X

X Mon Sep 24 13:45:08 2007

X <ES> client 1 initializing ....

X

X Mon Sep 24 13:45:09 2007

X Using implementation std

M <EsNT> Memory Reset enabled as NT default

X ES initialized.

M

M Mon Sep 24 13:45:15 2007

M calling db_connect ...

C Found ORACLE_HOME=E:\ORACLE\V5C\920 in Registry

C Client NLS settings: AMERICAN_AMERICA.UTF8

C Logon as OPS$-user to get SAPR3's password

C Connecting as /@V5C on connection 0 ...

C Attaching to DB Server V5C (con_hdl=0,svchp=04A25ACC,svrhp=04A27D54)

C

C Mon Sep 24 13:45:35 2007

C Starting user session (con_hdl=0,svchp=04A25ACC,srvhp=04A27D54,usrhp=04A3055C)

C Now I'm connected to ORACLE

C *** ERROR => ORA-1403 when accessing table SAPUSER

[dbsloci.c 9990]

C Disconnecting from connection 0 ...

C Closing user session (con_hdl=0,svchp=04A25ACC,usrhp=04A3055C)

C Now I'm disconnected from ORACLE

C Try to connect with default password

C Connecting as SAPR3/<pwd>@V5C on connection 0 ...

C Starting user session (con_hdl=0,svchp=04A25ACC,srvhp=04A27D54,usrhp=04A3055C)

C *** ERROR => OCI-call 'OCISessionBegin' failed: rc = 1017

[dbsloci.c 3733]

C *** ERROR => CONNECT failed with sql error '1017'

[dbsloci.c 9643]

B ***LOG BY2=> sql error 1017 performing CON [dbsh#2 @ 962] [dbsh 0962 ]

B ***LOG BY0=> ORA-01017: invalid username/password; logon denied [dbsh#2 @ 962] [dbsh 0962 ]

B ***LOG BY2=> sql error 1017 performing CON [dblink#1 @ 419] [dblink 0419 ]

B ***LOG BY0=> ORA-01017: invalid username/password; logon denied [dblink#1 @ 419] [dblink 0419 ]

M ***LOG R19=> tskh_init, db_connect ( DB-Connect 000256) [thxxhead.c 1146]

M in_ThErrHandle: 1

M *** ERROR => tskh_init: db_connect (step 1, th_errno 13, action 3, level 1) [thxxhead.c 8562]

M

M Info for wp 1

M

M stat = 4

M reqtype = 1

M act_reqtype = -1

M tid = -1

M mode = 255

M len = -1

M rq_id = -1

M rq_source = 255

M last_tid = 0

M last_mode = 0

M int_checked_resource = 0

M ext_checked_resource = 0

M report = > <

M action = 0

M tab_name = > <

M

M *****************************************************************************

M *

M * LOCATION SAP-Server SAPCCVM5_V5C_00 on host SAPCCVM5 (wp 1)

M * ERROR tskh_init: db_connect

M *

M * TIME Mon Sep 24 13:45:35 2007

M * RELEASE 620

M * COMPONENT Taskhandler

M * VERSION 1

M * RC 13

M * MODULE thxxhead.c

M * LINE 8694

M * COUNTER 1

M *

M *****************************************************************************

M

M Entering TH_CALLHOOKS

M ThCallHooks: call hook >ThrSaveSPAFields< for event BEFORE_DUMP

M *** ERROR => ThrSaveSPAFields: no valid thr_wpadm [thxxrun1.c 672]

M *** ERROR => ThCallHooks: event handler ThrSaveSPAFields for event BEFORE_DUMP failed [thxxtool3.c 238]

M Entering ThSetStatError

M Entering ThReadDetachMode

M call ThrShutDown (1)...

B dbtbxbuf: Buffer TBX_SINGLE not available

M ***LOG Q02=> wp_halt, WPStop (Workproc 1 2424) [dpnttool.c 346]

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Sep 24, 2007 at 10:46 AM

    Hi Ezhil,

    For the log, its because the dispatcher unable to connect to your database.

    First try with R3trans -d first and see the log (trans.log)

    Second, please apply the sapdba_role.sql (you can read the instuction inside the script)

    Hope this help solve your problem,

    Fendi Suyanto

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Did you try to login on the database with SAP DB User SAPR3/pw?

      sqlplus /nolog

      connect SAPR3/pw

      If not, you should change the password for the SAP Database user with BR*Tools.

      e.g. like that and then try again.

      brconnect -u system/pw -f chpass -o sapR3 -p <new password)

      Do OPS$ User exist and have right permissions?

      If you don't have OPS$ Users, you should create them.

      select username from dba_users where username like '%OPS%'

      Do you have SAP User Table? If not, you can create SAPUSER Table according to the SAP Note.

      400241 - Problems with ops$ or sapr3 connect to Oracle as Fidel Vales already mentioned it.