Skip to Content
0

Negative quantity value displayed in ALV is converting to char when viewing the excel

Sep 01, 2017 at 04:00 PM

67

avatar image
Former Member

Hello,

I am trying to display negative quantity value- MENGE in ALV grid display and while viewing the data in excel , this column is getting converted to text field.

As i need to perform summation on the this column, changing the cell format also not helping.

Please let know how to get the value to retained in the same format in excel without no manual intervention on excel.

Thanks,

Narayan

alv-output.jpg (15.3 kB)
alv-output.jpg (15.3 kB)
excel-output.jpg (28.8 kB)
10 |10000 characters needed characters left characters exceeded

It's because Excel wants "-100", i.e. minus sign upfront. Have you tried searching in Google? I'm pretty sure a similar question has been asked before...

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Nic Teunckens Sep 01, 2017 at 10:14 PM
0

A few things :

  • Have you set / indicated in the FieldCatalog of your Output (ALV-Column) that your Quantity is actually defined as a Quantity Field?
  • Have you set / indicated in the FieldCatalog of your Output (ALV-Column) to allow a Sign in your Output?
  • Which datatype is your "Quantity"-Column? Is it a Z-Type or a SAP-Standard Numeric / Quantity field? Try using a type such as "MENGV" ...


If not, please check up on you FieldCatalog and make Adjustments ... Test it again.

If you still encounter problems, check with different Exporting Options => For example : Export as '.txt' and viewing it as Spreadsheet ...

Share
10 |10000 characters needed characters left characters exceeded