Skip to Content
0

Web Intelligence - Optimize report for printing not possible

Sep 06, 2017 at 09:00 AM

75

avatar image

Hello,

one of my customer is using a Web Intelligence Report which I built several weeks ago. Now they want to print the report and also create PDF File.

The problem is that the output is pretty confusing, headers and tables gets split and there are also a lot of blank pages between the sites.

I tried to optimize the report and used the "Page View" to see which content gets printend and how it fits to each site. I moved all the tables and columns (which is really time consuming by the way) but the result is still bad.

I am not able to get rid of the blank pages.

When I optimize the first page/tab (which gets split on 3 pages when printing) I am missing a chart on the following page. I fixed that with the result that the first page got destroyed and now showing the whole content on one page (too small to read when printing).

Is there an easy way to optimize the Web I report for printing? How to get rid of the blank pages and how to avoid that already formatted pages loose their layout when changing another page?

Thanks in advance.

Br, Mario

10 |10000 characters needed characters left characters exceeded

how many tables and charts in your webi report and number of columns in table?

other option you can try if you have multiple tables/charts then place table/chart one by one top to bottom.

Genric issue for blank pages is some part of table is moving on the second page.

0

The report contains 11 pages. 8 of them are containing 1 or 2 charts (mostly line charts).

On the other pages there are small tables (please see screenshots attached).

0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Mario Panzenboeck Oct 10, 2017 at 12:46 PM
0

Finally I opend up an SAP support ticket and the problem is actually a bug in Web Intelligence.

There is a note which describes the behaviour: 2232441

This issue should be fixed with BI 4.1 SP 6 patch 3.

Share
10 |10000 characters needed characters left characters exceeded
AMIT KUMAR
Sep 06, 2017 at 09:29 AM
1

on the second screenshot i saw title is big.may be that is causing the issue when it is going on the second page.Other then that you tables are small.

check your report in Structure mode if some cells are placed in right side. Uncheck auto width options on cells.

or select page orientation is Landscape and decrees the left/right margin.


1.png (14.9 kB)
2.png (4.3 kB)
Share
10 |10000 characters needed characters left characters exceeded
Mario Panzenboeck Sep 06, 2017 at 11:15 AM
0

Hello Amit,

thanks for your advices - for now they don´t solve my problem.

I checked the settings for the pages and tried different setups.

Checked the structure - I think there´s nothing incorrect here:

Landscape and A4 is selected. Checked Width 1 Page, auto, and also height 4 Pages, Auto, ...

Also tried to set the option "Start on a new page" for the titles or tables:

Now I have a table with several pages. With the Site - View everything looks fine. At the bottom I can scroll to the next pages:

The result in PDF looks like the following: First Table (4 Pages) are fine:

Table 2 is empty:

...and should look like this (correct in Site View - Preview):

Next table with several tables on each site is also not working:

Any ideas how to fix this?

Thanks!


1.png (18.7 kB)
2.png (14.3 kB)
3.png (15.9 kB)
4.png (61.1 kB)
pdf1.png (38.6 kB)
pdf2.png (7.4 kB)
pdf4.png (18.7 kB)
pdf3.png (43.5 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

use relative position to align chart with last table.set the distance between last table and chart like 0.5 and see if still blank page is coming or not between table & chart.

0