Skip to Content
avatar image
Former Member

Invoice numbers are missing

Hello friends while creating invoice the numbers are missing, for example we assign number range between 1 to 100 for a perticular invoice, once the invoice is created the system should take invoice number between 1 to 100 in a sequential manner , if the previous invoice number is suppose 55 the next invoice numbers should be 56,57,58... but my problem is after 55 it is taking as like 63, what could be the reason for this, can any one of you help me

Thanks in advance,

vk

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Sep 22, 2007 at 06:09 AM

    Hi,

    <b>This is because the Same Number range has been assigned to some other Transaction</b>. May be it is Invoice or Delivery or sales order or anything. Check the number range assignment in SNRO, to find out the bug.Since the other transaction is also using same number range, hence without your knowledge, the serial numbers are being assigned to those other documents. Hence this inconsistency.

    Reward if this helps.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 22, 2007 at 06:09 AM

    hi kiran,

    this sprblem cud be due to number range buffering activation, locks on the NRIV table or some OSS application not being present.

    check for the number range object in SNRO. For normal invoces the object type is RV_BELEG. check if buffering is activated. it has to be deactivated by going into the edit option at the top. be careful while making thse changes.

    check lock enteries in SM12 on NRIV table. theyu have to be removed.

    call SAP if the problem persists- may be some OSS notes is missing

    saurabh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 22, 2007 at 06:12 AM

    HI

    Start Transaction SNRO and enter the affected object.

    - Choose the pushbutton 'Change'.

    - Deactivate buffering: Choose 'Edit' -> 'Set Up Buffering' -> 'No Buffering'.

    - If you only want to change the buffer size, enter the corresponding value in the field 'No. of numbers in buffer'.

    - Save the changes.

    Please note that this change is a modification. The modification is overwritten as soon as the affected number range object is redelivered - in other words, you must check the change manually each time you import a release.

    Object for Customer Number Ranges is xxx

    To Summurize:

    Check T.Code: SNRO

    Object: xxx

    No. of numbers in buffer: maintain it as '0'

    Sail

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 22, 2007 at 07:13 AM

    Try Checking in VF05...Put missing nos of invoices...

    See what system response is...

    REWARD IF U FINDS THIS AS USEFUL...

    Regds

    MM

    Add comment
    10|10000 characters needed characters exceeded