Skip to Content
author's profile photo Former Member
Former Member

Installation of SAP SolMan 4.0 SR2 on AIX 5.3/Oracle

We have already installed SolMan 4.0 successfully in our dev sys--so we know this can be done. Now we are trying to start the sapinst to install our prod system and can't get the SAPInstGUI to recognize the sapinst running on the same server.

We have:

-installed the newest IBM JDK 1.4.2 SR8

-set SAPINST_JRE_HOME=/usr/java14_64/

-set TEMP, TMP and TMPDIR

When we run ./sapinst as root, it stops, apparently waiting for the GUI:

Starting GuiServer using:

/usr/java14_64/bin/java -cp /mnt/temp/sapinst_exe.360628.1190411815/JAR/instgui.jar:/mnt/temp/sapinst_exe.360628.1190411815/JAR/inqmyxml.jar -Djava.security.egd=file:/dev/urandom SDTServer config=jar:sdtserver.xml guiport=21212 sapinsthost=localhost sapinstport=21200

load resource pool /mnt/bs2005/BS_2005_SR2_SAP_Installation_Master/IM_AIX_PPC64/resourcepool.xml

guiengine: no GUI connected; waiting for a connection on host r09prd01, port 21200 to continue with the installation

We have als attempted to start using ./sapinst -nogui and ./sapinst SAPINST_START_GUI=false, which gives the same message. We then try to start the SAPInstGUI as <SID>adm, the GUI will generate a screen with the following message:

"Could not connect to host r09prd01 on port 21212. java.net.ConnectException: A remote host refused an attempted connect operation."

What are we missing to get this install started?

Add comment
10|10000 characters needed characters exceeded

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 26, 2007 at 04:56 PM

    Thanks to all for your suggestions.

    Unfortunately, our solution was a little more mundane, but was still effective. We changed all the ulimits for root to "unlimited" and the InstGUI launched without a problem.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Kent, mundane is fine if it works.

      I've always been successful with setting:

      ulimit -s unlimited

      ulimit -d unlimited

      Before triggering the SAPINST program. Have fun!

  • Posted on Sep 21, 2007 at 10:52 PM

    If the GUI is also running on the same system, login as root, check that your DISPLAY variable is correctly set and start ./sapinst. This will start the backend installation and will start the gui automatically.

    --

    Markus

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 25, 2007 at 07:48 PM

    Kent,

    A very good alternative here is also to run your SAPINST GUI from your local PC and connect back to the server (avoids latency with GUI rendering). You can download the SAPINST components for your say Windows PC (I386) then connect back by running the startinstgui.bat locally. Then enter in the IP address of the server and you are running.

    You can also test the sapinstgui on it's own (make sure you've set your JRE_HOME again first...)

    ...<installmaster>/im/imaix/SAPINST/UNIX/AIX_64/startInstGui.sh

    as root to see if there are any immediate issues.

    Also, since you are running this on AIX, did you confirm if there are any updates as outlined in note 929929? I know that for our ECC/BW installs, this was critical.

    Hope this helps.

    Tim

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 25, 2007 at 08:29 PM

    Kent,

    Set Environment Variables then

    Open 2 sessions.

    Run: <Installation Directory>/sapinst –nogui (in one session )

    Run: <Installation Directory/startInstGui.sh –standalone ( in one session say Putty )

    Hope this will help you.

    Thanks

    Kalyan.

    Reward if answer is helpful.

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 28, 2007 at 07:17 AM

    Hi,

    I am trying tom install SOLMAN4.0SR2 for ERP2005 IS RETAIL, here i am getting java error and i am not able to continue installation. Error is java JDK does not a valid directory i am getting

    Os: SUN10/AMD64MACHINE

    Patches : followed as per sap note 908334

    Java version tried : 1.5.0,1.4.2_09,1.4.2_13,1.4.2_12 also.

    I am struggling since 3 days, please some one respong i am very much greatful to your hlep ... please help me

    Error:

    INFO 2007-09-27 21:38:08

    Execution of the command "/usr/jdk/j2sdk1.4.2_09/bin/java -classpath /tmp/sapinst_exe.4931.1190909239/JAR/ins-j2ee.jar -d64 com.sap.ins.j2ee.GetSystemProperty" finished with return code 1. Output: Unrecognized option: -d64Could not create the Java virtual machine.

    ERROR 2007-09-27 21:38:08

    MUT-03023 Directory /usr/jdk/j2sdk1.4.2_09 is not a valid JDK directory: execution of "/usr/jdk/j2sdk1.4.2_09/bin/java -classpath /tmp/sapinst_exe.4931.1190909239/JAR/ins-j2ee.jar -d64 com.sap.ins.j2ee.GetSystemProperty" finished with return code 1.

    ERROR 2007-09-27 21:38:08

    FCO-00011 The step setDefaults with step key |NW_Onehost|ind|ind|ind|ind|0|0|NW_Onehost_System|ind|ind|ind|ind|1|0|NW_getJavaHome|ind|ind|ind|ind|1|0|setDefaults was executed with status ERROR .

    Regards,

    Sankaranarayanan.G

    BASIS CONSULTANT

    CHENNAI,INDIA

    Add comment
    10|10000 characters needed characters exceeded