Skip to Content
0
Former Member
Sep 21, 2007 at 06:04 PM

Missing tables; trying to r3load -merge_bck to complete; not working

167 Views

Hey again all,

I would be able to start my weekend in great fashion if this Solution Manager 4.0 installation would finish. I completed the SCS and Database instance installation and started the Central instance installation (Redhat EL5/Oracle 10g/64-bit) before encounting an error when it went to start the instance. The r3trans errors could not connect to the database (and I did confirm it was running).

I followed note 400241 to check the connect to the database and I was able to login as OPS$<os user>. But I was not able to see the SAPUSER table. Then when I viewed all user table (select table_name,owner from all_tables) that table was not visible nor were any tables belonging to the SAP<SMD> user. This tells me the database load did not finish.

I found note 454368 that indicated R3load probably did not finish. In fact when I look in my sapinst_instdir/.../DB directory I see the file DDLORA.TPL.bck that indicates to me the load did not finish. As per note 455195 I tried to restart R3load with the -merge_bck option. However that failed with the following output:

> R3load -merge_bck

sapparam: sapargv( argc, argv) has not been called.

sapparam(1c): No Profile used.

sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline

Segmentation fault

I understand the SAPSYSTEMNAME error can just be ignored on unix systems (note 32785) but I cannot determine what is causing the segmantation fault.

So...first of all, can someone help be find out why the database load did not complete, and secondly what do I need to do to complete it?

Thanks.

Steve