Skip to Content
0

Text fields print inches out of place from design view when printed any ideas?

Sep 05, 2017 at 09:52 PM

60

avatar image
Former Member

20170905190353.png

I am designing a 3 part NCR preprinted report for an IBM Wheelwriter Typewriter with 12 characters per inch Horizontal & 6 lines per inch Vertical printwheel. I have scanned in the pre-printed form as a jpg 2197 x 1698 pixels @ 200 dpi (10.99 x 8.49 inch), I have this in a picture box in the VS Pro 2013 update 5 with CRforVS_13_0_20.1502797732. I mostly did this to help me correctly positon all my text fields but, the preview at runtime is nice. More to the point this picture box is in the report designer measuring 10.99 x 8.49 inches exactly what I need. I have all margins set to 0.00 in the picture box and in the report Page Setup. I have placed (3) text fields at top left, top right & lower right of the page I have tried 10 & 12 pt. Courier New.

When printed to the typewriter the text in the field at top left is exactly positioned the problem is that the field at top right & lower right is printed about 2 inches short of the correct horizontal position and the lower right is also about 1 inch short of the correct vertical position.

Can anyone help me correctly position the text fields?

20170905190353.png (32.2 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Don Williams
Sep 06, 2017 at 10:07 PM
0

Have you configured the printer for custom paper sizes?

Did you use/create a custom paper size in CR Designer Page Setup?

Try unchecking Scaling or try my printer test app on the download page:

https://wiki.scn.sap.com/wiki/display/BOBJ/Crystal+Reports%2C+Developer+for+Visual+Studio+Downloads

Don

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Not sure where “unchecking Scaling” is located.

Also didn’t see the app link if you think it will help what area of the page is the link?

I did do a custom page in print server properties but in CR page setup always defaulted back to “Letter Extra” when I selected it (after reopening page setup). Long story short I tried everything with “No Printer” CkBox, “Dissociate” CkBox, Selecting My Page, I think at one time CR listed a custom page & I put in the size but I think it all ways went back to “Letter Extra”.

Refer to attachments. The most improvement was finding the formula (Font = 120/CPI) then I know monospace font at 12 CPI will be 10 pt. but always default to 9.75 pt. (that why before “AAA…” did not make it too far right) so then finding in the “Format Object Dalg” in FONTS Tab “Character Spacing Exactly” and setting = 5.9 pts. with “Lucida Sans Typewriter” font. Got a full 8.5” textbox of “AAA…”

So really this mostly fixed me… refer to CR_Report_preview.png

In the design view the signal line of “AAA…” & the “BBB…” are aligned Right. & the “Page 1 of 1” is as well.

I can’t figure why it always is misaligned when printed. I was going to export out as PDF and try printing it on typewriter then but CR must export as a graphic so I get blank page. By the way the PDF looks correct. Not sure what to do now but thank s for you suggestions so far. I hope someone can help with the alignment issue.

typewriter-output.png cr-design.png cr-report-preview.png
0
Don Williams
Sep 08, 2017 at 06:13 PM
0

Open the report in CR Designer, Click on the Print from the File Menu and you can set the scaling there.

Other option is to change the default Print Button to use POC rather than the P2P API. Property of the Viewer and can be set in code also.

See if POC works better, it uses the same Print Dialog as CR Designer uses.

Don

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

My print driver does not have any option for scaling. It is a Generic/Text Only. Just a reminder this is a monospaced typewriter 12 CPI 6 LPI.

In some research I found someone setting the paper to “US Std. Fanfold” 14.8 x 11 and keep portrait to support 132 chrs per line. Doing this and placing the text fields exactly 6 LPI (each field is 240 height (240 * 6 =1440)) and lining up the field tops on lines from different columns with each other all cross the page has helped. Also moving horizontally out past 11” so my picture and text fields now do not match up but that’s not a problem. When it prints out is what maters most. There has to be scaling going on here I did not try POC or P2P, don’t really know what that is but if it has to do with scaling I’m sure it would help. I’m happy with this workaround maybe I go back later and play with those settings.

Thanks for helping.

0
Don Williams
Sep 12, 2017 at 02:10 PM
0

POC = PrintOutputController - selectable Print Option in code or Viewer properties.

P2P is PrintToPrinter - default printer API from Viewer's print button

Share
10 |10000 characters needed characters left characters exceeded