Skip to Content
avatar image
Former Member

sap.ui.model not found

Hello Experts,

I am new to UI5 developments. I have installed Eclipse Neon and also installed all the SAP Plugins. I did not get any error. However, when I am checking the plugins, I am unable to find any of the plugins starting with sap.ui.model.

Can you please suggest how do I get them installed?

Thanks & Regards,

Amit

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Sep 05, 2017 at 12:01 PM

    who told you it is needed......

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I was going through one of the tutorials and in the screenshot, under SAPUI5 core libraries, they had shown sap.ui.mode.odata and hence was wondering why I was not able to see it.

      However, I was able to proceed further and then get the result.

      Thank you for the response.

  • Sep 05, 2017 at 12:54 PM

    SAP is recommending WebIDE which you can via SAP Cloud Platform. Eclipse is not the way to develop anymore as far is i know.

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 05, 2017 at 01:15 PM

    https://archive.sap.com/discussions/thread/3832551

    In addition to what the links threads state Web IDE is the strategic IDE for UI5 apps.  The UI5 tools created for eclipse are now longer supported and the recommendation is to use Web IDE.

    Web IDE is being developed rapidly and is offering way more Eclipse does.

    Add comment
    10|10000 characters needed characters exceeded

    • did you really read the thread? I am well involved in the discussion.

      furthermore I believe web ide is not free, if my info is still up to date