Skip to Content
author's profile photo Former Member
Former Member

Dates coming from web service

Hi,

I'm currently trying to consume in VC a CAF Application Service exposed as a Web Service. I'm able to retrieve what I want but I have a problem with dates format.

The web service returns dates in the following format: YYYY-MM-DDTHH:NN:SS

When I test my data service in VC it works fine. When I run my iview, VC swap the month and the day and compute the new date...

It's not just a problem of formatting with DVAL and DSTR because the date is already computed.

Example:

Date returned from web service: 2007-09-21T00:00:01

Date returned from test data service in VC: 21.09.2007

Date returned at runtime: 09.09.2008

VC understand 21.09.2007 not like DD.MM.YYYY but like MM.DD.YYYY so 21.09.2007 becomes 09.09.2008

I also tried to check on the server Regional and Language option but it doesn't come from there.

Have you ever faced this problem?

Thx

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Sep 21, 2007 at 11:12 AM

    Hi Thomas,

    Can you give me more details about web service?

    Like web service url.

    Regards

    Pramod

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.