Skip to Content
avatar image
Former Member

Getting java.net.MalformedURLException: no protocol error

Hi,

I have developed one sample application in webdynpro by using adobe interactive forms.

after deploying it, giving error like

java.net.MalformedURLException: no protocol:

at java.net.URL.<init>(URL.java:537)

at java.net.URL.<init>(URL.java:434)

at java.net.URL.<init>(URL.java:383)

at com.sap.engine.services.webservices.jaxrpc.wsdl2java.soapbinding.HTTPTransport.createHTTPSocket(HTTPTransport.java:110)

at com.sap.engine.services.webservices.jaxrpc.wsdl2java.soapbinding.HTTPTransport.getRequestStream(HTTPTransport.java:319)

... 40 more

configured latest credentials in server, running fine.

could you any one help out me.

Regards

Srikanth

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Oct 14, 2009 at 11:13 AM

    Hi Srikanth,

    Eventually it is now past 2 years but i wanted to know whether you were able to find a solution for the above exception you have posted ? because now i am getting the same exact exception and i am unable to trace out what actually is the problem.

    If you have solved this issue then request to kindly share the same with me.

    Also, SDN' s if anyone has faced the same exception earlier and have solved it then kindly share.

    Thanks In Advance,

    Vipin.

    Edited by: Vipin Vijayan on Oct 14, 2009 1:14 PM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Forgot to post the solution here!

      I have solved the issue at that time and the problem was with the configuration of ADS in the server.

      It is while setting up the basic authentication for adobe document services inside

      Web Service Clients -> sap.com / tcwdpdfobject ->

      com.sap.tc.webdynpro.adsproxy.AdsProxy*ConfigPort_Document the destination should be changed to Custom and need to provide it as

      pointing to your localhost:portnumber/AdobeDocumentServices/Config?style=document preceeded by http://

      which will solve the problem.

      With Regards,

      Vipin.

      Edited by: Vipin Vijayan on Dec 11, 2009 9:53 AM