Skip to Content
author's profile photo Former Member
Former Member

IGS-Charts in BSP: Series dependent custiomizing

Hello,

I'm trying to change some customizing settings for concrete Series in the ICG Chart, rendered using IGS XML, but cannot make it work. The example is given below. No matter what I set for LineColor in Customizing section, no change happens. Any hints are appreciated.

<%@ extension name="Graphics" prefix="graphics" %>

<graphics:chart width="800" height="500" igs_rfc_destination="IGS_RFC_DEST">

<graphics:custom>
<graphics:nativexml>
<?xml version="1.0" encoding="utf-8"?>
<SAPChartCustomizing version="1.0">
<GlobalSettings>
  <Dimension>Two</Dimension>
  <Defaults>
   <ChartType>Lines</ChartType>
  </Defaults>
</GlobalSettings>

<Elements>
 <ChartElements>
  <Background>
    <Color>RGB(255,255,255)</Color>
  </Background>
  <Title>
    <Caption>Ein Beispiel von Chart</Caption>
  </Title>
 </ChartElements>
</Elements>
<Values>
  <Series id="Series1">
   <LineColor>RGB(222,0,0)</LineColor>
   <Color>RGB(222,0,0)</Color>
  </Series>
  <Series id="Series2">
   <MarkerSize>15</MarkerSize>
   <LineColor>RGB(0,222,0)</LineColor>
   <Color>RGB(0,222,0)</Color>
  </Series>
</Values>
</SAPChartCustomizing>
</graphics:nativexml>
</graphics:custom>
<graphics:data>
<graphics:nativexml>
    <?xml version="1.0" encoding="utf-8"?>
    <SimpleChartData>
        <Categories>
            <C>Year 2001</C>
            <C>Year 2002</C>
            <C>Year 2003</C>
        </Categories>
        <Series id="Series1" label="Series1">
            <S>10</S>
            <S>20</S>
            <S>50</S>
        </Series>
        <Series id="Series2" label="Series2">
            <S>50</S>
            <S>80</S>
            <S>10</S>
        </Series>
    </SimpleChartData>
</graphics:nativexml>
</graphics:data>
</graphics:chart>

Thanks

Aal

Message was edited by:

Andrey Alimov

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Sep 20, 2007 at 01:14 PM

    Hi Aaal,

    try using <b>customizing</b> instead of <b>id</b> in the data XML, i.e.

    <Series customizing="Series1" label="Series1">...

    Then it should work as expected.

    Best regards

    Matthias

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.