Skip to Content
author's profile photo Former Member
Former Member

hi friends, i am new to webdynpro

when i am executing the webdynpro application with two windows and three views

its going to dump giving the error "The lead selection has not been set. VIEW_1"

and in the RAISEELEMENT_NOT_FOUND of program CL_WDR_CONTEXT_NODE===========CP

can anybody tell me where i did the mistake.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 20, 2007 at 08:26 AM

    Hello Shyam,

    You can use the cardinality 1..n and set intializeleadselection to true.

    Also, if you have cardinality 0..n or 0..1 and have lead selection set to true, then this error occurs when the node has no elements and you try to read an element (say in a table). So you need to take care of that too.

    Regards,

    Neha

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 19, 2007 at 09:37 AM

    Hi shyam,

    Make sure that,whether the Viewset's default property selected as true.

    check out the properties of table used in view.

    Regards

    Nandha.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 19, 2007 at 11:46 AM

    Hi,

    make sure that the context nodes you want to display in your tableviews

    have the cardinality of 1..N, 0..N

    grtz,

    Koen

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.