Skip to Content
0
Former Member
Sep 14, 2007 at 11:15 AM

LWE (Life and Work Events) to other countries and not for US

21 Views

Hi to all,

The LWE standard is working very fine, but I have to put the LWE working for Portugal (Molga 19). I apply the note 929447, bu I still have problems. I'm testing with Process MyFirstDays

What I have made:

In the Portal, in the GP Procedures, Design Time I've made the next steps:

-> copy all ths objects from folder "LWE - US" to the folder I created (one by one) - "LWE-PT";

-> create 4 new objects (with the web Dynpro specific for the country Portugal) and 4 new actions for: Address, Personal Data, Bank Information and Family/Dependents;

-> in the callable object I inserted the Inputs you say in the note:

1. Address: sap.xss.gp = X; sap.xss.menusrv = Employee_Persinfo_Address05;sap.xss.service = Employee_Persinfo_Address05;

2. to others I put the right service for Bank, Family and Perssonal data;

-> after I check and update all the blocks with the right action and callable object: so every process have the services specific for portugal (address, bank, personnal data, family);

-> I checked the roles and in the overseer I put all the users that are going to use the LWE and in the administrator the user who is going to manager the LWE Processess;

In the backend (i think that my problem is here):

-> create a resource with the right instantiation (diferent from the standard):

Resource: EMPLOYEE_LIFEWORK_FIRSTDAYS_PT_SERVICE

sap.com/cafeugpuiinst

Ainstantiation

process.template.id=CFF87F40620511DCCB370019BB3DB11C&process.autostart=true

-> Create in the specific services for countries:

Service: EMPLOYEE_LIFEWORK_FIRSTDAY

Molga: 19

Resource: EMPLOYEE_LIFEWORK_FIRSTDAYS_PT_SERVICE

-> Like say in the note I've made the entry in table T7XSSSERSRVCG:

Service Key: Employee_Lifework_FirstDays

Service Link text: First Days

Service Type: WebDynpro Applications

Link Resource: blank

This is all I've done in the backend. The link MyFirstDays in Life and Work Events in the portal dissapear 😔

I notest that in the note says: "NOTE THAT THE SERVICE KEY HAS TO BE EXACTLY THE SAME AS DEFINED IN THE DEFAULT VALUE IN ACTION" - are they refering to "EMPLOYEE_PERSINFO_ADDRESS05" (dependent of the service) or to the service "EMPLOYEE_LIFEWORK_FIRSTDAY" ??

Did I miss something? Can anyone help me?

I'm working with ESS1.0, EP7.0, ERP2005, ECC6.0.

Thanks in advance,

Sónia

Message was edited by:

Sonia Santos