Skip to Content

Error during SAPControl Connect Data step

Hi SAP gurus,

During creation of SAP S/4 Hana 1610 SAP Instance based on a system copy, in the Define parameter phase (Software provisioning manager) I am getting following error Error during SAPControl Connect Data step.

Caught ESAPinstException in module call: Error during execution of HdbCmdClazz 'GET_DEFAULT_DATA_BACKUP_LOCATION'

: class com.sap.hdb.sl.lib.utils.cmd.clazz.CmdClazzParameterFactory, parameters received. Start execution. Check HdbCmdOut.log
and HdbStdout.txt for further information.
Wed Aug 30 13:23:54 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | Client received SOAP Fault from server
: Invalid Credentials Please see the server log to find more detail regarding exact cause of the failure.. The last few lines from HdbCmdOut.log files are: Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.sl.lib.utils.cmd.clazz.GetDefaultDataBackupLocation | Default database backup location: $(DIR_INSTANCE)/backup/data Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | Error during execution of HdbCmdClazz section! Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | Client received SOAP Fault from server: Invalid Credentials Please see the server log to find more detail regarding exact cause of the failure. Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sun.xml.internal.ws.fault.SOAP11Fault.getProtocolException(SOAP11Fault.java:178) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sun.xml.internal.ws.fault.SOAPFaultBuilder.createException(SOAPFaultBuilder.java:116) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sun.xml.internal.ws.client.sei.StubHandler.readResponse(StubHandler.java:238) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sun.xml.internal.ws.db.DatabindingImpl.deserializeResponse(DatabindingImpl.java:189) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sun.xml.internal.ws.db.DatabindingImpl.deserializeResponse(DatabindingImpl.java:276) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:104) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:77) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sun.xml.internal.ws.client.sei.SEIStub.invoke(SEIStub.java:147) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sun.proxy.$Proxy34.parameterValue(Unknown Source) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.utils.SAPControlHelper.getInstanceDirectory(SAPControlHelper.java:48) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.utils.cmd.clazz.GetDefaultDataBackupLocation.getDefaultDataBackupLocation(GetDefaultDataBackupLocation.java:99) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.utils.cmd.clazz.GetDefaultDataBackupLocation.getDefaultDataBackupLocation(GetDefaultDataBackupLocation.java:131) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.sl.lib.utils.cmd.clazz.GetDefaultDataBackupLocation.execute(GetDefaultDataBackupLocation.java:136) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.core.main.cmd.HdbCmdMain.execute(HdbCmdMain.java:113) Wed Aug 30 13:48:13 CEST 2017 | com.sap.hdb.core.main.cmd.HdbCmdMain | com.sap.hdb.core.main.cmd.HdbCmdMain.main(HdbCmdMain.java:74)Any suggestion how to eliminate this error to go forward with installation?Many thanks in advance,Regards,Joshita
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Aug 30, 2017 at 02:10 PM

    Hello Joshita,

    I get the exact same error while doing a System copy of a HANA DB.

    Did you find a solution for this error?

    Regards,

    Michael

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 30, 2017 at 02:11 PM

    In the log you can find:

    Invalid Credentials Please see the server log to find more detail regarding exact cause of the failure

    So I would start with checking if the username / password you have entered are correct.

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Bartosz,

      the credentials I am giving are correct. Because if I try them on OS-Level they work.
      The SWPM/sapinst is asking for the <sid>adm credentials.
      If I log on to the host with the <sid>adm and the Passwort, everything is fine.

      Regards,

      Michael

  • Aug 31, 2017 at 06:29 AM

    Hello Bartosz,

    the credentials I am giving are correct. Because if I try them on OS-Level they work.
    The SWPM/sapinst is asking for the <sid>adm credentials.
    If I log on to the host with the <sid>adm and the Passwort, everything is fine.

    Regards,

    Michael

    (double-posting because I don't know if others can see the comment)

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 31, 2017 at 09:07 AM

    Hi Guys,

    I have always given the correct username/password for this particular installation.

    The problem lies somewhere else. Enen I have put the correct input in my global.ini file. <persistence layer>

    Donno how to proceed. :-(

    Regards,

    Joshita

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 02, 2017 at 02:50 PM

    Hi Joshita,

    I encountered the same problem during migration - import into target system. I followed SAP Notes 1563660 to change parameter service/protectedwebmethods to DEFAULT in instance profile. Then restart the service and SWPM. It went through.

    Cheers,

    Adhi

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 19 at 06:59 AM

    Sorry guys but is not passing over this error doing the 1563660 changes;

    SWPM19 during Hana system copy it pops this error on and on on SAPControl Connect Data step. No detailed error but:

    Error during execution of HdbCmdClazz 'GET_DEFAULT_DATA_BACKUP_LOCATION' : class com.sap.hdb.sl.lib.utils.cmd.clazz.CmdClazzParameterFactory, parameters received. Start execution. Check HdbCmdOut.log and HdbStdout.txt for further information. Thu Apr 19 07:47:13 GMT+01:00 2018 | com.sap.hdb.core.main.cmd.HdbCmdMain | Client received SOAP Fault from server: Invalid Credentials Please see the server log to find more detail regarding exact cause of the failure.

    while HdbCmdOut.log says:

    Thu Apr 19 07:47:13 GMT+01:00 2018 | com.sap.hdb.sl.lib.connection.sql.JdbcConnection | Run SQL command: SELECT VALUE FROM "PUBLIC"."M_INIFILE_CONTENTS" WHERE FILE_NAME = 'global.ini' AND SECTION = 'persistence' AND KEY = 'basepath_databackup' AND LAYER_NAME = 'SYSTEM' Thu Apr 19 07:47:13 GMT+01:00 2018 | com.sap.hdb.sl.lib.utils.cmd.clazz.GetDefaultDataBackupLocation | Default database backup location: /hana/backup/data Thu Apr 19 07:47:13 GMT+01:00 2018 | com.sap.hdb.core.main.cmd.HdbCmdMain | Error during execution of HdbCmdClazz section! Thu Apr 19 07:47:13 GMT+01:00 2018 | com.sap.hdb.core.main.cmd.HdbCmdMain | Client received SOAP Fault from server: Invalid Credentials Please see the server log to find more detail regarding exact cause of the failure.

    Please bring some light on what input fields: database sid adm, password, SAP Control WSDL URL string do and expected values/ check methods

    Add comment
    10|10000 characters needed characters exceeded