Skip to Content
0

Analytics Cloud (BusinessObjects Cloud) HANA Live Connection

Aug 29, 2017 at 01:37 PM

93

avatar image

Hello Everybody!

We want to connect the Analytics Cloud (BusinessObjects Cloud) with our HANA Database via Webdispatcher.

We have done the settings like the online documentation of the cloud, but the connection test via https://<webdispatcher> -in this case the loginscreen of the cloud should be opened- does not work. We always get the error "Connection Refused" (on Webdispatcher).

If we open the url https://<webdispatcher>/sap/bc/ina/service/v2/GetServerInfo we get the expected JSON answer.

With best regards,

Thorsten

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Julian Jimenez
Aug 30, 2017 at 06:31 PM
1

Hi Thorsten,

What is the error that you get in your Web Dispatcher logs?

It is possible that it is not accepting the certificate from our SAP Analytics Cloud. You need to added in your webdispatcher's PSE as a trusted certificate.

Regards,

Julian

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Julian,

thank you fpr your answer. we proofed our connection and it seems to be a certification error.

The Web Dispatchers log says "Try to connect xxxx.xx.sapbusinessobjects.cloud ... Connection refused"

We try to import all certificates from the cloud into the webdispatcher pse and try it again.

Regards

Thorsten

1
Tammy Powlas
Aug 29, 2017 at 01:39 PM
1

Hi Thorsten - please review this recently released SAP Note/KBA - https://launchpad.support.sap.com/#/notes/2525234 - I hope it helps

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Tammy,

thank you for your anwser, but it doesn't work ... :-(

0
Thorsten Kalweit Sep 01, 2017 at 11:11 AM
0

This is the error log:

[Thr 2720] *** ERROR => NiBufIConnect: non-buffered
connect pending after 5000ms (hdl 121;XXX.XXX.XXX.XXX:443) [nibuf.cpp  4598][Thr 2720] *** WARNING => Connection request to
XXXXXX.eu1.sapbusinessobjects.cloud:443 failed (NIECONN_REFUSED)

Should we have to set the settings for "X.509 Issuer Name"?

Show 1 Share
10 |10000 characters needed characters left characters exceeded

It seems to be indicating only connection refused and not anything related to the certificate.

Do you need a proxy to connect to internet from your network?

You may need the extra PROXY=yourproxy:port at the end of the configuration in your .pfl file

wdisp/system_1 = SID=SAC, EXTSRV=https://yourtenant.eu1.sapbusinessobjects.cloud, SRCURL=/, SRCSRV=*:4310, PROXY=proxy:8080

In my example I need to use the server named "proxy" in the port 8080. And 4310 is the port where my Web Dispatcher is listening.

When you log in to the web admin tool in Web Dispatcher, go to the menu:

SSL and Trust Configuration > PSE Management > Trusted Certificates - Listing SAPSSLC.pse (as a client)

Verify that you have there one for *.eu1.sapbusinessobjects.cloud

If you don't have it, you can import it. This guide is a bit outdated but the section 5 shows you how to do it:

https://assets.cdn.sap.com/sapcom/docs/2016/03/0844080b-657c-0010-82c7-eda71af511fa.pdf

Regards,

Julian

0