Skip to Content
0

Lumira Designer 2.0 Sp2 - Edit Initial View - Error: Failed to Instantiate data source

Aug 30, 2017 at 04:11 PM

776

avatar image
Former Member

Hi,

We are getting an error in Edit Initial View

Scenario

we have a data source DS1 (based on universe), it has query prompt "Initiate Date" and result objects are Initiate Date, Profit Category and Amount, data to be displayed in cross tab.

after passing prompt value in Edit Initial View,getting an error ( refer attached)edit-initial-view-prompt-error.png

we thought it may be some date format issue, but then we changed the prompt to Profit Category which is just string like GFII, WCU etc. but still same error.

again we changed it, before it was query level prompt filter, we changed to universe prompt filter, but still the error is same

We google it a lot but no luck...

Kindly suggest ...

Thanks & Regards

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Tammy Powlas
Aug 30, 2017 at 04:26 PM
0

Hi - does your BI4.x platform meet the Product Availability Matrix standards? https://support.sap.com/content/dam/launchpad/en_us/pam/pam-essentials/TIP/SAP%20Lumira/SAP%20Lumira%202.0/SAPLUMIRA_PAM.pdf

If so, how did you install the add-on? Are you on BI4.2?

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Tammy,

Thanks Thanks for quick reply.

We BI platform 4.2 Sp4 Patch 01 with the support of SAP, yes we refereed the same PAM document.

Server is AIX 7.2

First we install on only 4.2 only, we were not able to install add-on, SAP sent us the PAM file and suggested to install Patch 01 ( there patch 02 is also there, but they said not to install)

Can it be Java issue, but Note mentioned in PAM page no 3 says no need to install JRE, it comes as package.

Request you to guide us to resolve the issue.

Thanks and Best Regards

0
0
avatar image
Former Member Aug 30, 2017 at 05:33 PM
0

Hi Tammy,

Thanks Thanks for quick reply.

We BI platform 4.2 Sp4 Patch 01 with the support of SAP, yes we refereed the same PAM document.

Server is AIX 7.2

First we install on only 4.2 only, we were not able to install add-on, SAP sent us the PAM file and suggested to install Patch 01 ( there patch 02 is also there, but they said not to install)

Can it be Java issue, but Note mentioned in PAM page no 3 says no need to install JRE, it comes as package.

Request you to guide us to resolve the issue.

Thanks and Best Regards

Share
10 |10000 characters needed characters left characters exceeded
Tammy Powlas
Aug 30, 2017 at 06:23 PM
0

So did you go to SP04 BI4.2 patch 1 and then install SAP Lumira 2.0 SP02?

Show 13 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Tammy

Yes, We applied patch first then install SAP Lumira 2.0 SP02.

Its show even list values for prompt, like for profit category, lov is GFII, WCU, after selecting value, click on Back and click ok, it give that error.

Thanks and Best Regards

0
Former Member

Steps followed Installation:

1: Fresh installation of SBOP BI PLATFORM 4.2 SP04 SERVER AIX

2: Applied SBOP BI Platform Servers 4.2 SP04 Patch 1

3: Install SBOP LUMIRA SERVER FOR BI PLATFORM 2.0 SP02 AIX

Development :

* We are creating Analysis Application on universe based on Relational Connection on single source

0

Did you try it with the eFashion data source that comes pre-delivered?

0
Former Member

Hi Tammy,

Its not configured in company evironment... is there any other way to test it ...if can make test scenario simple universe to just test.

Regards

0
Former Member

Hi Tammy,

I just created a simple scenario, only two objects and one universe prompt filter, still the error is same.

Same thing happening with query filter as well.

Is it a tool bug ?

Thanks and Regards

0

Hi - I would submit an incident to SAP Support. I'm at a loss. Good luck. I recommend referencing this thread.

0
Former Member

Thanks Tammy for the support,

I tried to raise an incident, but company id isn't working and person who has admin id, is on vacation will come back end of next week, till then I have to keep trying... as it is most critical part of the application as there are millions of records.

If you get something, please update here, I will keep checking.

Thanks...

Regards

0

Hi - in that case, I would call SAP Support directly - see https://support.sap.com/en/contact-us.html

0
Former Member

Thanks ... calling now, will reference this thread.

0
Former Member

Hi,

Issue is reported as bug, will be fixed in next patch release schedule on Week 40 2017, below is the reply from SAP

The fix will be available in release 2.0 SP2 patch 1.

The Lumira release schedule can be found in Note 2465894.

Regards

1
Former Member

Hi Tammy,

Finally I got the patch but I think, issue is partially resolved, now its accepting the prompt but getting three different error instances:

(scenario: Load in script : False)

1: Sometime I don't get the prompt in Edit initial view. (scenario: Load in script : False)

2: Sometime same error as it was before. (scenario: Load in script : False)

3: Sometime it shows the result in Edit Initial View after passing the prompt value but not in the layout after clicking ok. ( scenario: Load in script : False)

if I do (scenario: Load in script : True), still the same issue in the browser,

1: Sometime I get the prompt and sometime no prompt

2: Sometime same error as before

3: Sometime no change in data or no data at all

I am thinking to report this to SAP, so thought of taking your suggestion?

Please suggest...

Regards

Aseel

0

That sounds like a good plan...

0
Arijit Das Aug 31, 2017 at 12:28 PM
0

I am also facing issue with Lumira 2.0 SP02 on unx universe containing prompt. Looks like a bug to me. I tested the same on BIP 4.1 SP10 on windows server. Check: https://answers.sap.com/questions/292693/lumira-20-designer-error-on-universe-containing-me.html. Others are also facing same issue in BIP 4.1 SP09 and BIP 4.2 SP03 as well.

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Arjit,

Yeah, I checked your blog, I just calling SAP Service Desk, opening an incident.

Let see what we get.

Thanks..

0

Hi Aseel, Did you have any update from SAP ?

0
Former Member

Hi Arjit,

They are still looking into it, asking many questions, still answering their questions.

Regards

0