Skip to Content
avatar image
Former Member

File Sender Adapter: Content Conversion :Mandatory parameter 'xml.keyfieldN

i have a scenario where i had to pick a flat file and post it to RFC.

on the basis of keyfields i had to pick the values

<b>but i am getting mandatort field xml.keyfieldnamec: no value</b>

my flat file is of type :

E2EDL20 0200083662685

E2EDL24 02090000110786293200PCE

E2EDL24 02090000210786301895PCE

E2EDL20 0200083662685

E2EDL24 02090000110786293200PCE

E2EDL24 02090000210786301895PCE

My FCC parameters are :

RecordSet Structure :E2ED20,,E2E24,

RecordSet sequence :Ascending

Keyfield Name: KG

E2ED20.fieldNames KEY01,VBELN

E2ED20.keyFieldName KEY01

E2ED20.keyFieldValue 'E2EEDL20'

E2ED20.fieldFixedLengths 7,33

E2ED20.endSeparator 'nl'

E2ED20.processFieldNames fromConfiguration

E2E24.keyFieldName KEY02

E2E24.keyFieldValue 'E2EEDL24'

E2E24.fieldNames KEY02,POSNR,CHARG,LFIMG,MEINS

E2E24.fieldFixedLengths 7,29,10,4,3

E2E24.endSeparator 'nl'

E2E24.processFieldNames fromConfiguration

KEY01,KEY02 i had 2 field added in DataType to identify :E2EEDL20,E2EEDL24.

THx

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    Sep 10, 2007 at 07:02 AM

    which SP are you working on ???

    anyway try these in your FCC;

    RecordSet Structure :E2ED20,,E2E24,

    RecordSet sequence :Ascending

    Keyfield Name: KG

    E2ED20.fieldNames KEY01,VBELN

    E2ED20.keyFieldValue 'E2EEDL20'

    E2ED20.fieldFixedLengths 7,33

    E2ED20.endSeparator 'nl'

    E2E24.keyFieldValue 'E2EEDL24'

    E2E24.fieldNames KEY02,POSNR,CHARG,LFIMG,MEINS

    E2E24.fieldFixedLengths 7,29,10,4,3

    E2E24.endSeparator 'nl'

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Shabarish V Nair

      i tried the above two option , but still it not working...

      now again i have the error:

      Mandatory parameter 'xml.keyfieldName': no value found

      any other inputs .. requested.

      THx

  • avatar image
    Former Member
    Sep 10, 2007 at 06:53 AM

    Hi,

    what it says in Message Display Tool

    Regards,

    Akshay Jamgoankar.

    Message was edited by:

    Akshay Jamgaonkar

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 10, 2007 at 06:58 AM

    Hi,

    >>Keyfield Name: KG

    Remove this and try.. it will definately work...

    Regards

    Santhosh

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 10, 2007 at 07:06 AM

    Hi,

    The FCC u have provided..

    RecordSet Structure :E2ED20,,E2E24,

    RecordSet sequence :Ascending

    <b>>>Keyfield Name: KG</b>

    E2ED20.fieldNames KEY01,VBELN

    <b>>>E2ED20.keyFieldName KEY01</b>

    E2ED20.keyFieldValue 'E2EEDL20'

    E2ED20.fieldFixedLengths 7,33

    E2ED20.endSeparator 'nl'

    E2ED20.processFieldNames fromConfiguration

    U have specified the keyfield two times....

    either u can remove <b>>>E2ED20.keyFieldName KEY01</b> from fcc and change ut DT to have a field KG to hold the keyvalue or

    u can remove <b>>>Keyfield Name: KG</b> so that the field specified by the <b>field.keyFieldName</b> is used to identify the keyfield...

    Regards

    Santhosh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 10, 2007 at 06:42 AM

    Hi,

    You need to write .keyFieldlnName = ignore.

    Regards,

    S.RamNarender

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 10, 2007 at 07:24 AM

    Hi ajay

    if still the file is not picked try this and see

    Check the source file property whether it is readonly file

    regards

    yugapreetha

    Message was edited by:

    Yugapreetha T

    Add comment
    10|10000 characters needed characters exceeded