Skip to Content
author's profile photo Former Member
Former Member

Auto Logout

Hi Expert!

I have been set the rdisp/gui_auto_logout for the 20 minutes to kill the idle sessions, rdisp/keepalive already set to 20 minutes.

My users are complaining that when they are doing the foreground / background processing, users sessions are terminating on certain time.

Does the session will kill also on the foreground / background processing ?

I want to eliminate those sessions which are idle not to foreground processing !

Please adivse the expert solution.

REgards

Add a comment
10|10000 characters needed characters exceeded

Related questions

8 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Sep 09, 2007 at 09:05 AM

    Hi

    I have been set the RDISP/GUI_AUTO_LOGOUT parameter for the 20 minutes.

    Now, the idle users sessions are terminating in 20 minutes.

    the question is here that when our HR / FI Department executing the Posting / processing which takes longer time to finish, the foreground processing sessions are terminating.

    This paramater was resetting the Idle connections, how will i eliminate this situation not to terminate the foreground processing sessions.

    Please advise us.

    Regards

    Anwer Waseem

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 10, 2007 at 03:14 AM

    Hi Anwer,

    Parameter rdisp/gui_auto_logout is regarding to dialog process. Means, the session will be killed is only foreground processing. There will be no effect to background processing. If you wanna save the foreground processing, you can set the value of auto logout time to 0 (no limit time logon), but it is not recommended, considering about security problem. Otherwise, you can expand the auto logout time.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 10, 2007 at 06:10 AM

    Hi,

    rdisp/gui_auto_logout is for foreground sessions only. In case you don't want your session to terminate for some particualr process then you need to create a new session from the session you want to run the foreground process. Don't let the second session ideal for more than 20 mins. Let the foreground process run in the first session.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi guys

      Thanks to all of you again.

      I am fully agree to all of you that the idle sessions should be terminate not the processing sessions.

      I have one example about the HR Department, they are processing salary, which takes longer time, the sessions are not idle, Salary is in being process but the sessions are terminated with the certain time.

      any ides ?

      REgards

  • author's profile photo Former Member
    Former Member
    Posted on Sep 10, 2007 at 09:51 AM

    Hi Anwer,

    I understand that you have set rdisp/gui_auto_logout for the 20 minutes to kill idle sessions but what about rdisp/max_wprun_time if it is set to e.g . 10 min and your HR collegues are doing some processing in foreground which will be limited by this parameter.

    Pls check if any TIME_OUT dumps are observed.

    Regards

    Umesh

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 12, 2007 at 05:36 AM

    hi,

    u can check in the TC ST22.i think it is the problem of paramater rdisp/max_wprun_time.increse the parametre Value.

    regards

    ajai

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 12, 2007 at 05:58 AM

    HI

    Thanks to all of your valuable information..!

    I have observed from the experience and all your valuable information that foreground processing also terminating sessions after 20 minutes (set time in the paramater), i have been disabled this option for the while and the users has processed which was taking almost 30 minutes.

    also, i set the more value in wp_run_time paramater for the 30 minutes for the processing, if you will not set the paramater, processing will ended with the timeoout error.

    Thanks again to all of your expert opinion.

    Regards

    Anwer Waseem

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 12, 2007 at 05:58 AM

    Thanks again

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 12, 2007 at 06:13 AM

    Hi Anwer,

    Kindly reward with the Points if you feel answer was helpful!!

    Regards

    Umesh

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.