Skip to Content
avatar image
Former Member

looking for alternative identifiers CPA Cache failed ?

Hi Guys,

I have RFC-HTTP scenario. I have configured RFC sender adapter and i have a scheduled job on the sap sender side which is responsible for the sending the data to XI.

when i have debugged the Function module on the sap side it is failing at the CALL FUNCTION and it gives an error <b>" looking for alternative identifiers and CPA cache failed for cc_sap_send"</b>

I have checked the program id and it is same in the RFC of type 'T' defined in the sender SAP system and in the sender RFC CC. The sap system has proper LS name and it also registered correctly unser service 'adapter identifiers'.

I have also tried by removing the option verify sender system under advanced mode in the sender RFC and when i do this , <b>when i debug the RFC it is saying that sender BS is not found in the CPA Cache</b>

any help wpuld be reallly appreciated

Thanks,

srini

Message was edited by:

srinivas kapu

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Sep 06, 2007 at 03:08 PM

    Hi,

    This sender BS is mantained in XI SLD? Did you refresh the XI cache?

    Regards,

    Ricardo.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ricardo,

      I have solved the problem by unchecking all the adapter specificmessage attributes in the HTTP receiver

      Thanks for your suggestions

      Thanks

      srini