Skip to Content
0

User Defined Serach in SAP PI

Aug 24, 2017 at 10:15 AM

36

avatar image

Hi SDNites,

I have created a user defined search in SAP PI and it does not seem to be working. Below is the XML on which search is required,

<?xml version="1.0" encoding="UTF-8"?>

<ZTAG1>

<IDOC BEGIN="1">

<EDI_DC40 SEGMENT="1">

<All Control record Tags>

</EDI_DC40>

<ZTAG2 SEGMENT="1">

<ZTAG3>1418</ZTAG3>

</ZTAG2>

</IDOC>

</ZTAG1>

In the above, I am trying to search a value in ZTAG3. Can you please advise based on above what needs to be populated in Filter and Namespace Prefixes. Also when trying to search from SXMB_MONI, can you please advise what needs to be populated in User Defined Selection Criteria.

Regards,

Abhishek

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Raghuraman S Aug 24, 2017 at 10:42 AM
0

Filter should be something like below,ITs better to get it from mapping(if you can share the complete XML it will be great).

//ns0:ZTAG1/ZTAG3

And define ns0 ,this shouldn't be required as it looks like IDOC or you can try with IDOC default namespace.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Raghu for IDOC's i dont think you need any prefix or namespace a simple XPATH would suffice these are usually used for custom created structure or XSD's/WSDL.

Br,

Manoj

0

Yes Manoj.

Thanks for clarifying had a slight doubt that's why told its not required but still gave in case to add if its not working.

1