Skip to Content
0

Personas 3.0 - Can I update an existing JavaScript Library?

Oct 19, 2016 at 05:37 PM

77

avatar image

Hi,

Sorry to re-post this question, but my original was not answered and now that it has moved to the SCN archive, it appears that neither I nor anyone else can reply to it.

We are running Personas 3.0, SP03, with the most current client and kernel. I am creating JavaScript libraries, through the Personas Admin Resource Maintenance section. The libraries work fine, but I cannot find anyway to update an existing library.

I've tried opening the library, using the Change / Upload buttons, and uploading a modified file, but it always tells me "No changes found that need to be saved". I've also tried using the Show button, which opens the file, but if I make changes and save them, they do not update the library file (I'm not sure if they are actually saved anywhere).

My workaround is to delete the library I'm modifying and recreate it. That works but it generates a new GUID, which means I need to update any session.utils.include statement in my scripts. I find myself modifying the libraries a lot, especially during initial development, so this is not a very convenient method.

In my initial post, the one reply I received suggested it might be a bug. Is anyone else familiar with this issue? If it is a bug, is it being worked on? Either way, has anyone found a way to modify an existing JavaScript library?

Thank you very much for you help!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Tamas Hoznek
Oct 21, 2016 at 08:37 PM
0

Not being able to upload a changed .js file seems to be a bug. I verified that it indeed doesn't work in SP03 with the current patches applied. However it works OK in the system where SP04 is being developed.

I created an internal bug report for SP03 so hopefully this will be fixed soon via a note.

Share
10 |10000 characters needed characters left characters exceeded