Skip to Content
0

Help/Guide me for Solman_setup error

Aug 23, 2017 at 02:44 AM

222

avatar image

Hi Experts,

I have installed SOLMAN 7.1 SR1 and when I started to Tx SOLMAN_SETUP it will direct me to IE but after I logged J2EE_ADMIN i got an error of HTTP 500 Internal Server Error

Then i searched about this error, i have applied those solutions/answers but still same error.

These are the solutions that I have searched but still not working:

• I granted full access in my users

• I have checked Tx SICF, objects are active.

• I tried to add some parameters in Tx RZ10

icm/conn_timeout = 20000
login/accept_sso2_ticket = 1 / 2
login/create_sso2_ticket = 2 / 1
icm/host_name_full = <hostname>

• I tried to edit the hosts file using administrator user with these input

1st try : 10.0.0.18 <space> hostname . domain . com

2nd try: 10.0.0.18 <space> hostname <space>hostname . domain . com

Need your guidance with this. Thanks a lot

10 |10000 characters needed characters left characters exceeded

Hi experts,

Any help?

0

Hi Experts,

Anybody help me? this question is not yet resolved. :(

0

Hi All,

I would like to inquire if OSS1 / SAProuter are prerequisites for SOLMAN.

0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

avatar image
Former Member Aug 23, 2017 at 07:49 AM
1

Hi Tan,

Make sure the user you are trying to logon through has the correct access. In Solman just SAP_ALL is not enough.

The Workcenter authorization would also need to be given - SAP_SMWORK_xxxxxxxxxx

Also, you mentioned that you logged on as J2EE_ADMIN on the IE.... please don't logon as this user.

Login as your own user once you have given the roles as I mentioned above.

Curious::-- Why are you installing 7.1 now..... as 7.2 is released and 7.1 has a very limited future.??

cheers

Deepak

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Deepak,

Thanks for your response, I will take note of that. I have tried my own user with SAP_ALL, SAP_NEW, and a composite role SAP_SOLMAN_ADMIN_COMP but still HTTP 500 internal server error.

I just want to test first 7.1 and try 7.2 later on. Even it is not the latest version it should work right?

0
Prithviraj Rajpurohit Aug 23, 2017 at 03:02 PM
1

Hi Tan,

Please check sap note https://launchpad.support.sap.com/#/notes/1924693

Also request you to check java logs.

Regards

Prithviraj

Show 5 Share
10 |10000 characters needed characters left characters exceeded

Hi Prithviraj,

Thanks for your answer, I will get back to you after updating the sps of solman and applying the notes that you mention.

May I know where can I check the java logs?

0

Hi Tan,

You can check the Java logs in /usr/sap/SID/J*/work/ and /usr/sap/SID/J*/j2ee/cluster/server0/logs directory

Make sure you replicate the issue and then try searching the logs.

Regards,

Prithviraj

1
Prithviraj Rajpurohit

Hi Prithviarj,

I have updated the SPS of solman and applied the note that you have given to me but still can't access after logging in using my user. Is there any other tweaks/configuration that I need to do? Can you check below if I configured it right.

HOST FILE

10.0.0.18<space>hostname [ not working ]

10.0.0.18<space>hostname.domaindotcom <--- current in my host file *domain in computer properties is not configure

URL

http://<hostname>:8000/sap/bc/webdynpro/sap/wd_sise_main_app?sap-language=EN [ not working ]

http://10.0.0.18:8000/sap/bc/webdynpro/sap/wd_sise_main_app?sap-language=EN [ working but after logging in using user with roles and SAP_ALL/NEW still got the error of HTTP 500 INTERNAL SERVER ERROR ]

Please help me..

0

Hi Tan,

Please check if you find any logs in tcode SMICM and defaulttrace.log file

Regards,

Prithviraj

0
Prithviraj Rajpurohit

Hi Prithviraj,

Sorry for late reply, I just got back from my leave.

I found this error in trace file log [dev_icm] under tcode SMICM

[Thr 4240] *** WARNING => Connection request from (9/10/0) to host: pwdf2625, service: 1090 failed (NIEHOST_UNK
[Thr 4240] {0004cc1c} [icxxconn.c 2108]

and found this host buffer ( SMICM > Goto > Host Name Buffer > Display ).

and through browser I can access <hostname>:50000/sld perfectly fine but for port 8000 i got internal server.

Thanks.

0
Frank Schuler
Aug 23, 2017 at 05:32 AM
1

Hello Tan,

In my experience, it is a good idea to patch your Solution Manager installation to the latest SPS right after the installation and prior to running SOLMAN_SETUP for the first time.

Best regards

Frank

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Frank,

Thanks for your reply. I will try to update it to latest SPS.

Currently this solman server is only configured in a workgroup not in domain. should I add it to domain? or is it fine if I just configure it in host file? I just want to be sure cause if joining it in domain is needed then i need to request it to our IT dept which may take a lot of time.

0

Hello Tan,

Being part of a domain is not needed for Solution Manager to work, however I would consider it good practice especially when it comes to certificates for security and SSO purposes.

Best regards

Fank

1

Hi Frank,

I see thanks again, so I will remove my doubt that the problem is related in configuration of domain in host server.

I have another doubt that my problem is related to hostname. our hostname for solman is SAP-SOL-D. it has special character dash(-). I have read some that it may affect it, is it true?

Im accessing solman in IE using IP not hostname.

0