Skip to Content
author's profile photo Former Member
Former Member

Problem with search element in E-Recruitment

Hi All

We are currently in the process of implementing E-Recruitment 3.0 as an extension to ECC 5. I have configured the system and have been doing some unit testing, and have found that when I

- try to "Apply Directly" in tab "Career and Job". If I enter the reference details of the specific job it finds the specific. Or if I leave the input field blank and hit the search button, it returns all jobs posted. However, if I try using a the "Search for Jobs" link option, I get a consistent error "An internal error occurred. Please try again later"

When I check transaction SLG1.....and the error log says the termination occured in a program called CL_HRRCF_ABDTRACT_CONTROLLER==CM001 line 56 and CL_HRRCF_SEARCH_MASK_GROUP====CM00M line 15

Same thing happens when searching for candidates to assign requisitions to.

Has anyone come across this prolem before? Any help will be greatly appreciated, as we have a tight deadline.

Cheers

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Sep 20, 2007 at 02:41 AM

    Kingsley,

    In order for "Search for Jobs" to work, TREX is required. Additionally Jobs posting and Publications of requistions must be in released status.

    Take a look at note 1082004 for more info.

    Hope this helps.

    Sridhar

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 21, 2007 at 10:58 AM

    Hi and thanks for responding to my last note. TREX has already been setup, and has been tested

    from the back end. We put in search criteria to return results for data that we knew existed, and it reurned some results, so we know TREX works.

    When we search for jobs or candidates (in the portal) <b>without</b> specifying any criteria, the search function works, and returns a result of all candidates or jobs in existence. It only when we try to specify a search criteria that it returns zero entries found.

    I have checked these tables for consistency -

    - T77RCF_SPT_IC – Search Profile Information Categories

    - T77RCF_SPT_AF - Assignment of Fields to Search Profile Types

    - T77RCF_SM_ELEM - Standard SAP templates

    - T77RCF_SM_ASME - Standard SAP template elements

    - T77RCF_SMG_ASM - Standard SAP template groups

    - V77RCF_SMG_NAVI - Search template groups to applications

    Any other suggestions?

    Thanks

    Kingsley

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.