Skip to Content
0

How to read data from z-table using GET_RELATED_ENTITIES method?

Aug 24, 2017 at 02:45 AM

51

avatar image
Former Member

Hi everyone,

I have problem about load data to table view in block assignment.

I have button to create record in z-table. I want to refresh data of block assignment in web ui. But i don't know how do.

I found "ON_NEW_FOCUS" method to load data. I tried debug method and i saw sizetable attribute don't update in "GET_RELATED_ENTITIES" method.

This picture that was created when i click button.

Then i refresh web ui, data don't load.

Please help me to resolve problem.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member
Sep 01, 2017 at 02:22 AM
1

Hi,

I suppose the Z table was created via AET. You mentioned you created record in z-table. Did you click button "New" in the assignment block from the WebUI, enter data in the fields, click Save, then the data was saved in the Z table but the data was not visible in the WebUI? Did you change any related code after you generated the table enhancement?

You can put a breakpoint in CL_CRM_INTLAY_BTIL->READ_ORDERS and see if it gives the data for the Z table/relation.

Best regards

Abby

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member May 07 at 05:34 AM
0

Hello, have you solved this problem? I met the same question , would you please tell me ?

Share
10 |10000 characters needed characters left characters exceeded