$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: false, vro: false, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content
0

NWDS deploy error : Unsupported major.minor version 52.0

Oct 26, 2016 at 07:05 PM

689

avatar image

hello everybody,

I'm working with SAP PO 7.5 and my Workbench is NWDS 7.3

I implemented a BPM and when i try to deploy i have this error:

An internal error occurred during: "Deploying Development Components".
com/sap/engine/services/dsr/server/DSRTransferable : Unsupported major.minor version 52.0

The java version in PO is java 8.

and in my PC i installed the jdk1.8.0_101, and I also configured it in Preferences-Installed JRE.

where is the problem? any suggestion?

thanks in advance

Alessandro

z86pf.png (3.2 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

7 Answers

Best Answer
Iliya Kuznetsov Oct 27, 2016 at 11:26 AM
0

For your case if no NWDI is used, you really need NWDS 7.5, 64-bit JDK and very close version of SP (SP of NWDS and SP of PO). Get the appropriate NWDS from SWDC, the name is close to NWCEIDE05_0-80000648.ZIP

Share
10 |10000 characters needed characters left characters exceeded
Szabolcs Renyo
Oct 28, 2016 at 01:53 PM
1

Hi Alessandro,

I would like to clarify some thing. The NWDS what you are using is depends from the runtime system and from some other things as well:
Here you can find more information about it: https://blogs.sap.com/2014/03/26/nwdi-vs-nwdi-content/

The major.minor problem occur if you try to run your java class file with a lower version of JDK than the version of the "builder" JDK.

Additionally I would like to ask you that there is NWDI in your scenario?

If yes I could suggest to you that take a look at the following blog:
https://blogs.sap.com/2016/08/24/configuring-jdk-settings-with-nwdi/

I hope my answer was helpful to you.

Best regards,
Szabolcs

Share
10 |10000 characters needed characters left characters exceeded
Ryan Crosby Oct 26, 2016 at 08:48 PM
0

Hi Alessandro,

You'll want to check the project settings in NWDS if you are getting that error, especially if you recently installed version 8 as the studio would not automatically take that as your default Java version for projects.

Regards,

Ryan Crosby

Share
10 |10000 characters needed characters left characters exceeded
Praveen Gandepalli Oct 27, 2016 at 02:35 AM
0

Hi Alessandro,

If your PO version 7.5 SP03 then you need to use NWDS also 7.5 SP03 then only it will be compatible with your PO server then you dont get these problems.

Check below blog.

Stop using the wrong NWDS version! © – Have a smoother Eclipse experience

Regards,

Praveen.

Share
10 |10000 characters needed characters left characters exceeded
Iliya Kuznetsov Oct 27, 2016 at 11:22 AM
0

> If your PO version 7.5 SP03 then you need to use NWDS also 7.5 SP03

Very absurd. The only precise version equality is needed when enterprise application is built and deployed (but is not in any cases). Moreover for some tasks NWDS isn't required at all and you could use any Java IDE.

If you have NWDI and CBS, version of NWDS might be volatile in wide range.

Share
10 |10000 characters needed characters left characters exceeded
Raghuraman S Oct 31, 2016 at 05:35 AM
0

Hello Alessandro,

We had a similar issue,Download JRE corresponding to PI Version or lower than it and select the same in installed JREs in preferences and check.


captur11e.png (19.9 kB)
Share
10 |10000 characters needed characters left characters exceeded
Alessandro Pederiva Nov 22, 2016 at 08:49 AM
0

thanks a lot to everybody!

Iliya solved my problem. Anyway thanks again to everybody

Share
10 |10000 characters needed characters left characters exceeded