Skip to Content

Help,Please guide me in resolving problem in OMS2

Aug 25, 2017 at 10:44 AM


avatar image

Hi SAP gurus,

I am trying to create new material type copied from material type HAWA.

I want to check the option external number assignment with check but unable to check that option and getting error of "cannot save changes-inventory managed mpn is not active"

I request you to help me in resolving this error?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Mohsin Abbasi Aug 26, 2017 at 10:25 AM

Dear Sandeep,

I have created this scenario in my S/4 Hana client, You need to delete this material type and create new material Type with same description but please don't tick on "MANUFACTURE PART NUMBER" Because if you click on this MPN Box in OMS2, then you can't make the Tick on External Number range w/o check box. Please Just create new material type and click on External no. assignment w/o Check box and save.

Best Regards

Mohsin Abbasi

oms2.png (82.0 kB)
10 |10000 characters needed characters left characters exceeded
Jürgen L
Aug 25, 2017 at 11:06 AM

I am a bit confused, I have neither such message in SAPs message table T100, nor a field in OMS2 for "external number assignment with check"

I have there only "external number assignment without check"

Double click the message to retrieve its message number and let us know, also a screenshot from your OMS2 page would be good.

What does the F1 help text say for your field "external number assignment with check" ?

Are you in a certain industry solution?

10 |10000 characters needed characters left characters exceeded
sandeep koyya Aug 25, 2017 at 11:31 AM

Hi Jürgen L

Thanks for answering.Here are the attached screenshots

Please note that i am beginner and working on s/4 hana.

Again many thanks for answering the question

message-1.jpg (28.7 kB)
message-2.jpg (100.6 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Unfortunately I am not yet on S4, and I also do not have this message in my system.

The screen of OMS2 looks normal. Had you changed anything (except the description) after you copied from HAWA?

I would usually try the where-used function in SE91 to see in which program this message is triggered and what exactly was checked. You may also get to this info with debugging.