Skip to Content
0

SAP CP Portal - A general error occurred in the trial landscape

Aug 24, 2017 at 07:16 AM

140

avatar image

I get an error "A general error occurred" in the trial landscape. Clearing browser cache does not help. Another account in the trial landscape has same issue. Any solution for this?

https://flpportal- . dispatcher.hanatrial.ondemand.com/sites/adminspace#landingPage-show

2 calls get https 500 error.

/fiori/v1/notifications

/fiori/portal/v2/usage/collect

Console log:

Failed to load resource:
https://flpportal-<trial_account>.dispatcher.hanatrial.ondemand.com/fiori/v1/notifications?
siteId=9a28bae7-bf1c-407f-93ea-cd32ac523859&_=1503558135638
500 (Internal Server Error)
 
A general error occurred


Failed to load resource: 
https://flpportal-<trial_account>.dispatcher.hanatrial.ondemand.com/fiori/portal/v2/usage/collect?siteId=ALL_SITES☆tDate=2017-7-24%2000:00:00.0&endDate=2017-8-24%2000:00:00.0&_=1503558135639
500 (Internal Server Error)


A general error occurred
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Boaz Wimmer
Aug 24, 2017 at 08:25 AM
1

Hi Masayuki,

This issue is not reproducible on other trial accounts, so it's not a general issue in portal service in trial landscape.

Please check the following in your SCP account:

1. Your user is assigned to the TENANT ADMIN role (Portal service - Configure Portal - Roles)

2. In SCP trust - Local Service Provider, check that Configuration Type is set to Default.

3. 2. In SCP trust - Local Service Provider, check that Principal Propagation is set to Enabled.

4. If the account's trust is configured to use SCI, check that the tenant's name is in SCI correct.

5. Check if the browser you are using is preventing some cookies to be sent during the navigation

Best Regards,

Boaz Wimmer

SAP Cloud Platform, Portal service Operations

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Boaz,

My root case was that "Principal Propagation" was disabled in the Local Service Provider.

It works fine now. Thank you.

Regards,

Masa

0
Former Member

Hi Boaz,

I experienced the same behavior in my trial instance.

"Principal Propagation" needed to be enabled manually. I would recommend to enable it by default, to avoid that other end users are running in the same issue. After enabling it the portal editor runs smooth.

BR

Marcel

0