Skip to Content
0

[SAP HANA Provisionning] Cannot Skip First row in CTL file?

Aug 24, 2017 at 01:19 AM

29

avatar image
Former Member

Dear expert,

I tried to load some flat files directly into with CTL file.

I would like to skip the 1 row, however this directive is not accepted in HANA 1.0 SP9.

You can find below the CTL file:

IMPORT DATA

INTO TABLE "ZTEST_201706"."ZTEST"

FROM ‘hana/shared/HDB/HDB00/work/test.csv'

record delimited by '\r\n'

fields delimited by ','

SKIP FIRST 1 ROW

error log test.csv.err'

Do you know if it is supported in the new version?

As workaround, I put all the parameter in the SQL query:

truncatetable md_mara;

IMPORTFROM CSV FILE '/hana/shared/HDB/HDB00/work/test.csv'INTO" ZTEST_201706"."ZTEST"

WITH record delimited by'\r\n'

SKIP FIRST 1 ROW

field delimited by','

error log'test.csv.err';

Many thanks in advance for your help.

Kind regards

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers