Skip to Content


Aug 23, 2017 at 12:52 PM


avatar image

Hello Gateway Masters,

we own a 7.51 sp1 gateway sytem, and I tried to trace OData V4 requests in the system, but only V2 requests are captured. Is it planned to cover V4 in the future, or is it already available in a higher service pack ?

Thank you


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Pavan Golesar Aug 30, 2017 at 10:18 AM

Hi Attila,

SAP Gateway has started to support OData v4 with SAP NetWeaver 750 SP04.

oData v4 is not supported in NetWeaver 7.50 SP03

To solve your Query on Odata v4: You have to build new OData service using 'OData v4' as project type as current one is OData v2(assumed it as OData v2).

OData version 4 (V4) standard combines the requirements from existing SAP applications built with the OData version 2 (V2) protocol which enables us to build an OData service in SAP Gateway now which is using OData v2 this service will still run when SAP Gateway will also support OData v4.

Hope it help :-)

Pavan Golesar

Show 1 Share
10 |10000 characters needed characters left characters exceeded

7.51 sp1 > 7.50 SP4 ;). I have already implemented the OData v4 service, now I want to trace it.