Skip to Content
0

BAPI_CUSTOMERRETURN_CREATE

Aug 22, 2017 at 11:02 AM

62

avatar image
Former Member

Hi all,

I am creating a return with ref to Invoice via BAPI_CUSTOMERRETURN_CREATE.Invoice was created in May and it has MWST value 14%. Todays MWST is 12%. We expect the value 14% to be copied in the return as we create return with ref to Invoice.But the reality is that it creates the return successfully but it does copy 14% from Invoice and instead it takes today's condition value ie..12% .When I create manual return with ref to Invoice, it copies 14% from Invoice.Hence i believe copy control works fine.Copy control has "G" .Anyone has come across this issue and if so, please let me know the root cause

Regards

Jay

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
G Lakshmipathi
Aug 22, 2017 at 12:54 PM
0

I believe in the said FM, you have Service Rendered Date. Maintain that of the original billing document date and try.

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Lakshmipathi,

Great.I maintained Ser_Date same as Billing date in BAPI and fixed the problem.Thank you so much for your support

0

Nice that the issue is resolved. Close this discussion so that members who have similar requirement can easily trace this thread and take the inputs from here. Go through this Blog written by Jürgen L

0
Jürgen L
Aug 22, 2017 at 11:15 AM
0

Have a look into OSS note 988617 - Returns: Increase of tax on sales/purchases

it suggest a user exit

Share
10 |10000 characters needed characters left characters exceeded