Skip to Content
author's profile photo
Former Member

Can't find Java Heap Dump hprof file

Hi,

I am encountering Out Of Memory crashes on my EP J2EE and want to use the SAP Java Memory Analyzer tool to have a look at the Java Heap Dump.

If found a couple of blogs and wikis about how to get a Heap DumP

1. In SAPMMC right-click on the JEE Server process and select Dump Stack Trace

2. JVM parameter -XX:+HeapDumpOnOutOfMemoryError

The dump file should then be generated as

filename:

java_pid<pid>.hprof.<unique number>

folder:

/usr/sap/<system>/JC<instance>/j2ee/cluster/server<node>/

or /usr/sap/<system>/JC<instance>/j2ee/work

I tried a lot but could not finde a hprof file anywhere.

Free disk space on server drive is 166 GB (drive D:). JVM binaries are located on C: where 5 GB are free.

JVM is Sun j2sdk1.4.2_12

Does anyone have a hint where the dump file is written?

Can this be configured?

Best regards

Ingo

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    author's profile photo
    Former Member
    Posted on Aug 31, 2007 at 10:06 AM

    Hi,

    as Krum already wrote, for the SAP MMC to give you a heap dump you have to set the -XX:+HeapDumpOnCtrlBreak parameter.

    If you are not getting your dumps (which should be written into the working directory of the process), please do as Krum wrote and check whether your parameters are active or if you just can't find them, please look for an hprof file with a find tool or the Windows search if it is Windows that you run on.

    Please have a look on slide 14 in our JavaOne presentation here: https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/00ca7f0d-8ee6-2910-5d82-fc3e8dd25300. There we have put together as a reference how to configure the JVM correctly for a SAP application server installation.

    Hope this helps,

    Kind regards,

    Vedran

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 31, 2007 at 09:31 AM

    Hi Ingo,

    Which way to get a heap dump have you tried - through MMC or on OutOfMemory? Or May be both?

    To get the heap dump through the MMC one has to set in advance the java option:

    -XX:+HeapDumpOnCtrlBreak

    Can you look into /usr/sap/<system>/JC<instance>/j2ee/work/dev_server<N> if the parameters are really specified?

    Regards,

    Krum

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ingo,

      Thanks for you reply, the problem is -XX:+HeapDumpOnOutOfMemoryError is not Valid VM parameter.

      I solved the problem, by installing latest JDK1.4.2_15 update from sun.

      Regards,

      Anil