Skip to Content

Application crashes on startup on Windows Server 2008 R2

Sep 13, 2017 at 10:21 AM


avatar image

I'm using Visual Studio 2010 with Crystal Reports for VS version 13.0.2000.0.

My test application works fine on my development machine (Win 7 Ultimate x64) and on test machines running Windows 10, Windows 10 x64, Windows Server 2012 R2. However, my test application crashes immediately when I run it on Windows Server 2008 R2 SP1. I've tested on two different 2008 R2 servers and it crashes on both.

The crystal runtime is installed and .Net 3.5 is enabled.

This is the info windows is providing when the application stops:

Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: crystalreportsapplication1.exe
Problem Signature 02:
Problem Signature 03: 5997283b
Problem Signature 04: CrystalDecisions.CrystalReports.Engine
Problem Signature 05: 13.0.2000.0
Problem Signature 06: 58f5f6c1
Problem Signature 07: 62c
Problem Signature 08: cd
Problem Signature 09: FGSEXK01TN3ZHY53Q34U5O2SN1JUPVBS
OS Version: 6.1.7601.
Locale ID: 1033

Read our privacy statement online:

If the online privacy statement is not available, please read our privacy statement offline:

Does anyone have any suggestions?

Unfortunately, the production servers are all running Server 2008 R2 SP1.



10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Don Williams
Sep 14, 2017 at 10:02 PM

Check the support version on the download page:

13.0.2000.0 is the assembly version, never changes until SP 21. Need to know the SP you are using and distributing?

You are likely missing a dependency, Framework or VC 2005 C++ ATL Security runtime.

10 |10000 characters needed characters left characters exceeded