Skip to Content

SAP Time format to Oracle database JDBC Insert error

Aug 22, 2017 at 10:04 AM


avatar image

Hi Experts,

we get below error

JDBC message processing failed; reason Error processing request in sax parser: Error when executing statement for table/stored proc. OPERATORS (structure Statement): java.sql.SQLSyntaxErrorException: ORA-00917: missing comma

my scenario is ECC->PO->jdbc-error.jpgOracle Database(Jdbc adapter)

In this i am trying to insert the data into the database from PO system

while SAP ECC gives Time format as hh:mm:ss we tried to push the same into the database but it is not accepting

below is the screen shot of database oracle.jpg

how to convert the time format in mapping ..please throw some light on this

CreationDatetime is the field in database and same field name i am using in receiver structure

CreationDateTime xsd:Datetime


1)we have flexibility to ask time format from ECC in any form we want for SAP PO system

2)Date :we are not facing issue

Below is the mapping i have tried

Creation date from ecc+Creation time from ecc-->Concatination------------>CreationDateTime(Receiver)



oracle.jpg (15.1 kB)
jdbc-error.jpg (19.7 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Manoj K Aug 22, 2017 at 12:07 PM

Hi Guru,

You can embed the Date Conversion in your SQL query by mapping this filed to the conversion function such as TO_DATE so that this TO_DATE will execute on your oracle DB.



10 |10000 characters needed characters left characters exceeded
Rudra Singh Aug 22, 2017 at 12:31 PM

Hi Guru,

As Manoj suggested ... you need to use TO_DATE function in PI . Please fine the blog given below .

Warm Regards,


10 |10000 characters needed characters left characters exceeded