Skip to Content
0

PSA request Deletion issue in process chain

Oct 11, 2016 at 02:49 PM

797

avatar image

Dear Consultants,

I am in BW 7.4, I am trying to delete the PSA requests through process chain. The chain shows green but the process is not deleting PSA requests. Please find the attached screen shot and tell me where the setting is wrong in my PSA delete variant for mentioned data source.

Adding I only want to keep the last request of full load. I have tried the above thing also with exclude selection pattern. Please guide.

Regards,

Jawad

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

10 Answers

Frédéric Cincet Oct 14, 2016 at 12:49 PM
1

Hi Jawad,

What makes you thing your deletion doesn't work ?

Basically the deletion program only sets the flag DELFAG to X in the table RSTSODSPART. This is only a logical deletion.

Once all the PSA of a whole partition are logically deleted , the partition is dropped (and so are the PSA).

Regards,

Frederic

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Frederic Cincet,

My requests are shown in PSA table and as my DTP is on full load so it is duplicating my data in infocube. When I delete manually it deletes.

0

OK, what is the status of the DELFLAG of this PSA in the RSTSODSPART table ?

0
Nanda Anantha Oct 12, 2016 at 06:42 AM
0

Hi Jawad,

Check below two

Green check box (deletes only request which are quality check ok and updated successfully) so it will delete only requests which are satisfy these two conditions.

Red check box, it will delete requests which meets below conditions

1 ) the request should contain error.

2) not updated data target

3) no longer exist in data target,

Please check accordingly and re-run pc it will delete if condition meet.

Thank you,

Nanda

Share
10 |10000 characters needed characters left characters exceeded
John Hawk Oct 11, 2016 at 07:45 PM
0

Your settings appear to be correct.

Do you get an error in the process chain log? If so, please share.

Can you delete the requests manually? If there is an error, please also sahre.

Good luck!

John Hawk

Share
10 |10000 characters needed characters left characters exceeded
jawad Ksheikh Oct 12, 2016 at 06:17 AM
0

Hi John Hawk,

Yes, I am able to delete the requests manually and there is no error in process chains. I have had the same setting in all process chains for PSA request deletion but I am facing the issue in only few of them.

As I have had info-package on full load and I am deleting the cube requests daily and my DTP is on delta so if PSA requests not deleting it is giving me duplication of records in Cube.

If you have had any idea of this dual behaviour. Please Guide.

Regards,

Jawad

Share
10 |10000 characters needed characters left characters exceeded
John Hawk Oct 13, 2016 at 08:57 PM
0

Hi Jawad,

At this point, I would recommend you document the error in a Word document with screen shots, and open an SAP Note.

John Hawk

Share
10 |10000 characters needed characters left characters exceeded
Bhavin Vyas Oct 14, 2016 at 11:18 AM
0

try to uncheck the tick marks against the data source and older than value 1 day.

Thanks,

Bhavin Vyas

Share
10 |10000 characters needed characters left characters exceeded
Mario Tibollo Oct 14, 2016 at 01:40 PM
0

Does it work properly when you delete the PSA manually in the Workbench? How do you check that the PSA is not deleted? Do you check the entries in the table itself?

M.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Mario Tibollo,

Yes It deletes correctly when I delete manually. When I am deleting through chain the requests are displayed in PSA and my data is duplicating in cube.

0

can you try without selecting the last two columns?

psa-del.jpg (12.9 kB)
0
Donnie Burhan Oct 17, 2016 at 07:54 AM
0

Hi Jawad,

Seems like you experienced the ghost record problem.

I got this kind of problem once in a blue moon too and going by the front door doesn't help much.

Could you try go to SE14 and put in the PSA table name (Not DataSource name).

If you want to delete the entries, then just pick Delete database table, or maybe try Activate and adjust database with the radio button set at Delete data.

Share
10 |10000 characters needed characters left characters exceeded
Mallikarjuna Gande Oct 18, 2016 at 08:09 AM
0

Try input the date, instead no.of days and execute. And make sure you have selected correct source system. Thank you.

-

mgande


psa-delete.png (2.7 kB)
Share
10 |10000 characters needed characters left characters exceeded
Sourav Banerjee Oct 18, 2016 at 11:10 AM
0

Hi,

Normally PSA deletion happens 'logically'. It only creates a flag in the PSA table and the actual deletion happens segment wise at a later point of time. It deletes the logical display from PSA. The actual data would be available in the database PSA table for a while unless all segments are marked for deletion.

If the logical deletion too is not working then:

1. Try deleting the request manually once and see if the request is getting deleted from PSA manage.

2. Create a new variant and add it to process chain.

Share
10 |10000 characters needed characters left characters exceeded