Skip to Content
avatar image
Former Member

PSA request Deletion issue in process chain

Dear Consultants,

I am in BW 7.4, I am trying to delete the PSA requests through process chain. The chain shows green but the process is not deleting PSA requests. Please find the attached screen shot and tell me where the setting is wrong in my PSA delete variant for mentioned data source.

Adding I only want to keep the last request of full load. I have tried the above thing also with exclude selection pattern. Please guide.

Regards,

Jawad

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

10 Answers

  • Oct 14, 2016 at 12:49 PM

    Hi Jawad,

    What makes you thing your deletion doesn't work ?

    Basically the deletion program only sets the flag DELFAG to X in the table RSTSODSPART. This is only a logical deletion.

    Once all the PSA of a whole partition are logically deleted , the partition is dropped (and so are the PSA).

    Regards,

    Frederic

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 12, 2016 at 06:42 AM

    Hi Jawad,

    Check below two

    Green check box (deletes only request which are quality check ok and updated successfully) so it will delete only requests which are satisfy these two conditions.

    Red check box, it will delete requests which meets below conditions

    1 ) the request should contain error.

    2) not updated data target

    3) no longer exist in data target,

    Please check accordingly and re-run pc it will delete if condition meet.

    Thank you,

    Nanda

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 11, 2016 at 07:45 PM

    Your settings appear to be correct.

    Do you get an error in the process chain log? If so, please share.

    Can you delete the requests manually? If there is an error, please also sahre.

    Good luck!

    John Hawk

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 12, 2016 at 06:17 AM

    Hi John Hawk,

    Yes, I am able to delete the requests manually and there is no error in process chains. I have had the same setting in all process chains for PSA request deletion but I am facing the issue in only few of them.

    As I have had info-package on full load and I am deleting the cube requests daily and my DTP is on delta so if PSA requests not deleting it is giving me duplication of records in Cube.

    If you have had any idea of this dual behaviour. Please Guide.

    Regards,

    Jawad

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 13, 2016 at 08:57 PM

    Hi Jawad,

    At this point, I would recommend you document the error in a Word document with screen shots, and open an SAP Note.

    John Hawk

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 14, 2016 at 11:18 AM

    try to uncheck the tick marks against the data source and older than value 1 day.

    Thanks,

    Bhavin Vyas

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 14, 2016 at 01:40 PM

    Does it work properly when you delete the PSA manually in the Workbench? How do you check that the PSA is not deleted? Do you check the entries in the table itself?

    M.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 17, 2016 at 07:54 AM

    Hi Jawad,

    Seems like you experienced the ghost record problem.

    I got this kind of problem once in a blue moon too and going by the front door doesn't help much.

    Could you try go to SE14 and put in the PSA table name (Not DataSource name).

    If you want to delete the entries, then just pick Delete database table, or maybe try Activate and adjust database with the radio button set at Delete data.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 18, 2016 at 08:09 AM

    Try input the date, instead no.of days and execute. And make sure you have selected correct source system. Thank you.

    -

    mgande

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 18, 2016 at 11:10 AM

    Hi,

    Normally PSA deletion happens 'logically'. It only creates a flag in the PSA table and the actual deletion happens segment wise at a later point of time. It deletes the logical display from PSA. The actual data would be available in the database PSA table for a while unless all segments are marked for deletion.

    If the logical deletion too is not working then:

    1. Try deleting the request manually once and see if the request is getting deleted from PSA manage.

    2. Create a new variant and add it to process chain.

    Add comment
    10|10000 characters needed characters exceeded