Skip to Content
author's profile photo Former Member
Former Member

Problem in ALV list display

Hi all,

I have an issue in ALV list display. I have a field TXZ01 which has to display in 9th position in list display. But the field is in Hidden fields. how can i make that field to get displayed in 9th position for any varient.

FMs used in program are

'REUSE_ALV_VARIANT_F4

'REUSE_ALV_LIST_LAYOUT_INFO_GET

REUSE_ALV_FIELDCATALOG_MERGE----


calling entire structure

'REUSE_ALV_VARIANT_SELECT'

'REUSE_ALV_VARIANT_DEFAULT_GET'

REUSE_ALV_VARIANT_EXISTENCE'

Points will be rewarded.

Thanks in Advance,

Regards,

vineel

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Aug 29, 2007 at 10:19 AM

    hi vineel,

    you have to check the fieldcatalog for this field. looks like that the no_out field is marked for TXZ01.

    hope this helps

    ec

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 29, 2007 at 10:18 AM

    first remove the fieldcat-hide = 'x' [ comment this field] .......

    after commenting use

    fieldcat-fieldname = 'txz01' [ u r field name ]

    fieldcat-colpos = '9'.

    try this i hope it will work for u .....

    reward points if helpful....

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.