Skip to Content
avatar image
Former Member

Send mail to Message Processor in Service Desk

Hello

I am trying to create a action that will send mail to message processor when he is assigned to the support message.

The problem is that when a support message is created the filed of the message processor is empty and the action can't be preformed even after I am assigning a message processor the action isn't working.

Is anyone knows what kind of condition I need to had to my action so the action will be active only after I will assign a message processor.

Thanks a lot

Lior Grinberg

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Aug 24, 2007 at 03:04 PM

    Hi Lior,

    please provide all the settings for your action and its processing type details.

    regards,

    Jason

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi

      The details of the action:

      ActionProfile: SLFN0001_ADVANCED

      Action Definition: Z_SEND_MAIL_TO_MPC

      Processing Time: Processing when saving document

      Processing Times Not Permitted: No Restrictions

      Schedule Automatically

      PartnerFunction: SLFN0004

      Determination Technology: Determination Using Conditions that Can Be Transported.

      Rule Type: Workflow Conditions

      Action Merging: Max. 1 Unprocessed Action for Each Action Definition

      processing type :

      1. Smart Forms Mail.

      2. Form Name - ZCRM_MESSAGE_PROCESSOR.

      3. Processing Class - CL_DOC_PROCESSING_CRM_ORDER.

      4. Processing Method - CRM_ORDER_EXEC_SMART_FORM.

      5. Archive Mode - 1 Mail only.

      Tell if you need more infomation

  • avatar image
    Former Member
    Aug 26, 2007 at 12:13 AM

    Hi Lior,

    You can solve this trouble by the different variants. First variant can be in the next steps:

    1) Create new status in Schema of Status between "New" and "In process" with name "For employee"

    2) Define that message processor must be assigned rather than message will be in status "For employee" and create your action for status "For employee".

    Then you has next scheme:

    1. Message created, status "New"

    2. Message open for edit, assign employee as message processor, message saved

    3. Assign status "For employee" (action is defined), message saved (create e-mail to message processor).

    This is easy way as I can see.

    Also you can create action that will send e-mail for e-mailing list (1-st Level Support) when message was created in Service Desk.

    Say me if you have questions.

    Regards,

    Arkadiy

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I found the root of the problem,

      This error appears in my system when I have the same business partner in the Message Processor and in the Reported By.

      Regards,

      Roberto

  • Aug 26, 2007 at 06:48 PM

    Arkadiy

    "Also you can create action that will send e-mail for e-mailing list (1-st Level Support) when message was created in Service Desk"

    How do you do this. I can get it right if I Open message and save message. I want the message to be send immediately when it was created.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      We are also getting the same message in the determination log.

      =======================================================

      Number of action templates from the determination: 1

      Action is partner dependent, partner determination is performed

      No suitable partner has been determined

      No partner exists with role SLFN0004

      =======================================================

      Did you get the solution.