Skip to Content
0

In SOLMAN_SETUP, "No agent found" shows up for diagnostics agents

Oct 10, 2016 at 07:41 PM

1.2k

avatar image

I have Solution Manager 7.2 SP3 installed. I'm at the "Define CA Introscope" step in SOLMAN_SETUP. After I click the Discover Introscope EM button, the Diagnostics agents field shows "No agent found (N/A)". I have already installed a Diagnostics Agent on the Solution Manager server. Does anyone know how to resolve this? Thanks.

Henry

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Henry Leung Oct 16, 2016 at 07:09 PM
1

It looks like this is because the Diagnostics Agent was non-authenticated. This is how I resolve this issue:

  1. Following the directions in Note 2217545 (Execute the command smdsetup managingconf)
  2. Open the Agent Administration window (http://<solman_host>:<java_http_port>/smd/AgentAdmin). Under Agents > Non-authentication Agents, select the agent and click the Trust Agents button. This moved the agent to the Connected Agents tab.

Now the Diagnostics Agent instance shows up when I click the Discover Introscope EM button.

Share
10 |10000 characters needed characters left characters exceeded
Tom Cenens
Oct 14, 2016 at 06:58 AM
0

Hi Henry

You should check if your diagnostics agent is also connected to SAP Solution Manager. System preparation 6.7 Connect Diagnostics Agent.

There are multiple sources which can provide hints in case of issues:

https://wiki.scn.sap.com/wiki/display/SMSETUP/Introscope+Setup

1962333 - Responsibility of individual steps in transaction SOLMAN_SETUP and helpful notes or KBAs

Best regards

Tom

Share
10 |10000 characters needed characters left characters exceeded