Skip to Content
avatar image
Former Member

what is the " variant "null"" mean?

hi,after finishing my Web Dynpro Project,I built my project in DTR,an error happened.It said as follows:

2007-8-22 19:44:25 /userOut/Development Component (com.sap.ide.eclipse.component.provider.listener.DevConfListener) [Thread[ModalContext,5,main]] ERROR: md/wd/model/sla: Build failed for neusoft.com/md/wd/model/sla(neusoft.com_ASE_SC_1) in variant "null": null

-


Build log -


Development Component Build (2007-08-22 19:44:25)

Component name: md/wd/model/sla

Component vendor: neusoft.com

SC compartment: neusoft.com_ASE_SC_1

Configuration: E01_ASE_D

Location: E01_ASE_D

Source code location: http://neuesdnwep01:50100/dtr/ws/ASE/neusoft.com_ASE_SC/dev/inactive/DCs/neusoft.com/md/wd/model/sla/_comp/

DC root folder: C:\Documents and Settings\neusoft_1\.dtc\0\DCs\neusoft.com\md\wd\model\sla\_comp\

DC type: Web Dynpro

Host: HECJ

DC Model check:

All used DCs are available locally

-


At the same time,I checked the folder where the project in,and I found that there was a folder called "null" in the "gen" folder,and my there was almost nothing in my "gen" folder and its sub-folders.I don't know what happend.Hope to see your opinions.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Aug 23, 2007 at 02:32 AM

    Daniel,

    Looks like your Track creation configurations is not done properly. Check the following settings:

    - Go to CMS

    - Navigate to Landscape Configuration

    - Select the Track which you are working on

    - Select Track Data tab from available tracks.

    - In Software Components for Development View click on View/Edit XML Content.

    See if you have the following entries in additon to <dependencies> tag.

    <i><build-variants>

    <b><build-variant name="default" required-for-activation="yes"></b>

    <variant-mappings>

    <variant-mapping used-compartment="sap.com_SAP_JTECHS_1" used-variant-name="default"/>

    <variant-mapping used-compartment="sap.com_SAP-JEE_1" used-variant-name="default"/>

    <variant-mapping used-compartment="sap.com_SAP_BUILDT_1" used-variant-name="default"/>

    </variant-mappings>

    </build-variant>

    </build-variants></i>

    If not there add the above tags and change the Dependency SC names if you have other versions.

    Once you are done remove the Development Congfiguration from your NWDS and reimport the track.

    Regards

    Abhilash

    Add comment
    10|10000 characters needed characters exceeded