Skip to Content
author's profile photo
Former Member

Stuck in time difference between system time and time updated in table?

Hello there,

I am stuck in some wierd situation. I have a program, which I have to run in background, and which generates a spool. Now the requirement is, I have to get the spool number while the program execution in background and I have to mail that spool number.

We know that the spool ID gets populated in table TSP01, with user name, first 12 digits of program name and date-time key. I am able to gather the all the information need to get the spool number form the table TSP01.

However, the <b>time</b> with which the spool is getting updated in the <b>table</b> and the <b>system time</b>, they are different from each other.

When I debugged the program, the moment the entry populated in the table,

time in the TSP01 table was 2007082214525300 and the system time was 2007082207525300.

How do I get that time? Can anyone please help me with this.

Or if someone knows how to get the spool number in the different way than this, please tell me that also. I will be very grateful for your answers.

<b>Note: this time is made of YEAR:MONTH:DATE:HOUR:MIN:SEC:00 </b>

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    author's profile photo
    Former Member
    Posted on Aug 22, 2007 at 04:33 PM

    Hi,

    If this spool is being generated internal to your program, then sy-spono should have the value.

    Regards,

    Lijo Joseph

    Add comment
    10|10000 characters needed characters exceeded