Skip to Content
avatar image
Former Member

Error while trying to apply SP20 to Enterprise Portal 6.0

I am trying to upgrade my Enterprise Portal from SP13 to SP20, I am getting the following error message on one of the last steps.

***********************************************************

Start updating EAR file...

start-up mode is lazy

EAR file updated successfully for 3420ms.

Start updating...

EAR file uploaded to server for 10501ms.

ERROR: Not updated. Deploy Service returned ERROR:

java.rmi.RemoteException: Only Administrators have the right to perform

this operation.

at com.sap.engine.services.deploy.server.DeployServiceImpl.update

(DeployServiceImpl.java:656)

I also noticed that I cannot log on to the Visual Admin, I am getting the following error

____________________________________________________

Error while connecting

com.sap.engine.services.jmx.exception.JmxSecurityException: Caller

Guest not authorized, only role administrators is allowed to access JMX

_____________________________________________________

Does anyone know what is causing this error?

Thanks,

Alma C.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 22, 2007 at 06:05 AM

    Hello Alma,

    Try to login in visual admin through user j2ee_admin. with proper Authorizations/Roles.

    For your info

    J2EE_ADMIN - should have role SAP_J2EE_ADMIN.

    J2EE_GUEST - should have role SAP_J2EE_GUEST.

    SAPJSF - should have role SAP_BC_JSF_COMMUNICATION_RO.

    Regards,

    Jafer

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Alma.

      OOPs!!! I forget the that u had java only 😔

      For your problem go to User Administration and add user 'admin' to the Administrators group! Might it help this time

      Good luck!

      Jafer

  • avatar image
    Former Member
    Aug 22, 2007 at 08:34 AM

    Hi Alma,

    This is one of the security issue.We had faced it sometime back.We searched some CSN's and found a solution.

    Go to Service Market palce and download the latest Cryptographic Tool kit (Service Market place---->software downloads)

    You will get a sca/sda something like tc/iaik./security(something like this)

    Deploy this on to your instance using your SDM.

    After that,Restart the Portal patching.It will go fine.

    reward points if helpful................

    Add comment
    10|10000 characters needed characters exceeded