Skip to Content
avatar image
Former Member

problem in displaying ui elements

hi all,

I created one attribute in the context of component controller. dynamically i added some values to that attribute in the WdDoInit() method of the component controller.

In WdDoModifyView() method of view controller, i created the UI elements dynamically and i binded the attribute name to the radiobuttongroupbykey element. when i deploy this application, it is displaying the error as unknown child node......

how can i deploy and run the application without errors.

Thanks,

lalitha.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Aug 21, 2007 at 01:55 PM

    what is the code you are using

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 21, 2007 at 01:56 PM

    Hai Sri,

    1. please check into the UI element properties

    2. did u assign the corresponding attribute into the UI element value..

    thats all,

    Regards,

    P.Manivannan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 21, 2007 at 04:58 PM

    Hi,

    Try these steps. It might solve your problem

    1) Create an attribute say, <ctx_attr> of type string in Component Controller. Add the dynamic values to ctx_attr in WDDoInit().

    2) Select the WD Component, right click ---> Open the DataModeler.

    3) Select the connector arrow and drag from View to ComponentController. Select ctx_attr and drag from right to left. This is called Context Mapping.

    4) Bind the ctx_attr of the View to the SelectedKey property of radiobuttongroupbykey element.

    Build the project. Check if any errors are indicated.

    Make sure u havent done context binding of ctx_attr with any other UI element.

    Regards

    Arpita

    Add comment
    10|10000 characters needed characters exceeded