Skip to Content
avatar image
Former Member

Can't connect to PI instance - No space left on device

Hi all,

we have installed two instances on one host that share one Oracle DB. One SRM system and one NW 7.0 double stack with PI. The problem is that we can't connect to the PI system. SAP Logon says "connection refused" as if the server wasn't there.

sapstart finishes without any error message, R3trans -d doesn't give an error either.

dev_disp contains these lines:

  • ERROR => e=28 semget(28602,1,2047) (28: No space left on device) [semux.c 924]

  • ERROR => DpRqQInit: SemInit SEM_REQ_QUEUE_DIA_KEY [dpxxqueu.c 321]

  • DP_FATAL_ERROR => DpSapEnvInit: DpRqQInit

  • DISPATCHER EMERGENCY SHUTDOWN ***

No directory on the file system seems to be full though and there's about 10 gig of free RAM.

The OS is Solaris 10.

Thanks for any hints,

Paul

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 21, 2007 at 11:40 AM

    By the way, the /etc/project file contains the line

    <sid>:200:SAP System <SID>:<orasid>,<sid>adm::process.max-sem-nsems=(priv,2048,deny);project.max-sem-ids=(priv,1024,deny);project.max-shm-ids=(priv,256,deny);project.max-shm-memory=(priv,18446744073709551615,deny)

    for both instances.

    Maybe an issue with the shared memory?

    Please advise,

    Paul

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 21, 2007 at 11:48 AM

    Hi,

    Kindly try R3trans -x and check the logs.

    Apart from that it seems to be a memory allocation issue. Hence please check with the memory parameters of your SAP system.

    Regards,

    Prem

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Problem solved. The reason for the trouble was the fact that for some reason the setting for

      project.max-sem-ids

      was not effective although it was set correctly in /etc/project. By logging in again via

      su - <sid>adm

      it worked. Don't ask me why, but it helped.

      Paul