Skip to Content
author's profile photo
Former Member

Blank Dates not loading into an DSO

Hi Gurus,

I have a problem loading data into a DSO. This DSO has a bunch of date fields and is set to generate SID's upon activation. In the UR logic, some of the dates derived are found to be Zero or blank. When this gets updated into the DSO, the activation fails with the message '00000000' is not a valid date. I understand that, but my problem is the derived dates in the UR can have blank values logically and i want to show it in the report that those date fields are blank. How do i do this. This is a very important issue for us and anyone who gives a solution will be rewarded handsomely.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    author's profile photo
    Former Member
    Posted on Aug 21, 2007 at 06:27 AM

    Hello Dear

    When you are getting blank date , your update rule processes its value as 00000000,

    Now in the date conversion routine if you go , you will find that after the routine one exception is written for this value..means this value is not accepted.

    So maintain a date and load data.

    Award points if it solves your problem/concern

    Thanks

    Tripple k

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Aug 21, 2007 at 02:05 AM

    In your update rule when the date is zero what are you passing? Are you passing '00000000' or ' '. If you are passing '00000000' change that to ''. Internally those two are different.

    thanks.

    Wond

    Add comment
    10|10000 characters needed characters exceeded