Skip to Content
avatar image
Former Member

changing the field

Hello Guys,

I need to change the length of the data element for ztable for which i maintaining a maintainence view .i incremented the length of the field in domain and activated by using database utility .when iam supposed to enter entires in the view its is taking only previous length but not the incremened.pls let me know the solution its urgent.

Regards

Janapathi

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Aug 20, 2007 at 09:15 PM

    You need to recreate the table maintaince..

    first delete the table maintaince and again recreate it.

    now you should get it

    Thanks

    Seshu

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2007 at 10:37 PM

    Hi Janapathi,

    Delete the existing one and recreate afresh and try.

    Hope this helps.

    Please reward if useful.

    Thanks,

    Srinivasa

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 21, 2007 at 03:43 AM

    You can delete the existing table mainenance view and create a new one

    Utilities--> table maintenance generator.

    Press delete, and create a new one..

    Regards,

    SaiRam

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 21, 2007 at 04:42 AM

    Hi Janapathi,

    When you create a table maintenance, it creates a view through which it allows you to update the table entries. so if u have changed the table attributes u now require to change the view attributes by recreating the table maintenance for the table.

    Thanks,

    Jiten

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 21, 2007 at 02:05 PM

    just you need to delete the existing one(what you create before) and recreate the new entry and maintain the table.

    go for

    Utilities -


    > Table maintanance Generator

    vasu...

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      hey guys problem is solved.i went to view and deleted table maintanance there and created table maintemnace .now its working fine.

      Thanks for you help

  • Aug 22, 2007 at 06:27 PM

    hi friend

    you can change the length of the field. you no need to delete the table and recreate. Instead of the after changing the length activate and goto>utility>database maintanence .

    click that and u will see the big button at the last that is adjust the table button click that. your table will automatically set to new length.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 23, 2007 at 11:29 AM

    Hello Janapathi,

    first modify yhe existing dateelement than GOTO SE14.

    Give the ZTABLE name press the EDIT button.goto next screen

    inthat screen there is option called ACTIVE and ADJUSTDATABASE.

    once active that table automatically changes are reflected to particular table.

    Thank's.

    Patil

    Add comment
    10|10000 characters needed characters exceeded